summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Iskar Enev <iskar.enev[@]gmail.com>2010-05-11 20:02:02 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:02:02 +0200
commit68ad816bf7f964bd92fce455e86bf51f9e8739ad (patch)
treeddd3cfc0126f610913a5ee5c9a0ca5d840eaa323
parentcaba00dee0659b8a0cc4d1e97d15c69261a51c06 (diff)
downloadslackbuilds-68ad816bf7f964bd92fce455e86bf51f9e8739ad.tar.gz
slackbuilds-68ad816bf7f964bd92fce455e86bf51f9e8739ad.tar.xz
system/lshw: Added to 12.0 repository
-rw-r--r--system/lshw/README15
-rw-r--r--system/lshw/gtk-lshw.desktop10
-rw-r--r--system/lshw/lshw.SlackBuild63
-rw-r--r--system/lshw/lshw.info8
-rw-r--r--system/lshw/slack-desc19
5 files changed, 115 insertions, 0 deletions
diff --git a/system/lshw/README b/system/lshw/README
new file mode 100644
index 0000000000..f917315f0f
--- /dev/null
+++ b/system/lshw/README
@@ -0,0 +1,15 @@
+lshw (Hardware Lister) is a small tool to provide detailed information on
+the hardware configuration of the machine. It can report exact memory
+configuration, firmware version, mainboard configuration, CPU version and
+speed, cache configuration, bus speed, etc. on DMI-capable x86 or EFI
+(IA-64) systems and on some PowerPC machines (PowerMac G4 is known to work).
+
+Information can be output in plain text, XML, or HTML.
+
+It currently supports DMI (x86 and EFI only), OpenFirmware device tree
+(PowerPC only), PCI/AGP, ISA PnP (x86), CPUID (x86), IDE/ATA/ATAPI, PCMCIA
+(only tested on x86), USB, and SCSI.
+
+On x86, lshw needs to be run as root to be able to access DMI information
+from the BIOS. Running lshw as a non-root user usually gives much less
+detailed information.
diff --git a/system/lshw/gtk-lshw.desktop b/system/lshw/gtk-lshw.desktop
new file mode 100644
index 0000000000..4508355786
--- /dev/null
+++ b/system/lshw/gtk-lshw.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=LSHW
+Comment=HardWare LiSter
+Categories=Application;System;
+Icon=/usr/share/lshw/artwork/logo.svg
+Exec=/usr/sbin/gtk-lshw
+Type=Application
+Terminal=false
+Encoding=UTF-8
+
diff --git a/system/lshw/lshw.SlackBuild b/system/lshw/lshw.SlackBuild
new file mode 100644
index 0000000000..c2f2017712
--- /dev/null
+++ b/system/lshw/lshw.SlackBuild
@@ -0,0 +1,63 @@
+#!/bin/sh
+
+# Slackware build script for lshw
+# Written by Iskar Enev <iskar.enev[@]gmail.com>
+
+PRGNAM=lshw
+VERSION=B.02.12.01
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Fix the MANDIR variable
+sed -i "s%MANDIR=\$(PREFIX)/share/man%MANDIR=\$(PREFIX)/man%" src/Makefile
+
+RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" make
+RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" make gui
+make install DESTDIR=$PKG
+make install-gui DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $(find . -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/share/applications
+cat $CWD/gtk-lshw.desktop > $PKG/usr/share/applications/gtk-lshw.desktop
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/* COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/lshw/lshw.info b/system/lshw/lshw.info
new file mode 100644
index 0000000000..1bc5aad38e
--- /dev/null
+++ b/system/lshw/lshw.info
@@ -0,0 +1,8 @@
+PRGNAM="lshw"
+VERSION="B.02.12.01"
+HOMEPAGE="http://ezix.org/project/wiki/HardwareLiSter"
+DOWNLOAD="http://ezix.org/software/files/lshw-B.02.12.01.tar.gz"
+MD5SUM="7aeacdd0b86ae03acbc168d8ecdf6fd6"
+MAINTAINER="Iskar Enev"
+EMAIL="<iskar.enev[@]gmail.com>"
+APPROVED="rworkman"
diff --git a/system/lshw/slack-desc b/system/lshw/slack-desc
new file mode 100644
index 0000000000..d4f134373c
--- /dev/null
+++ b/system/lshw/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-------------------------------------------------------|
+lshw: lshw (Hardware Lister)
+lshw:
+lshw: lshw (Hardware Lister) is a small tool to provide detailed information
+lshw: on the hardware configuration of the machine. It can report exact
+lshw: memory configuration, firmware version, mainboard configuration, CPU
+lshw: version and speed, cache configuration, bus speed, etc. on
+lshw: DMI-capable x86 or EFI (IA-64) systems and on some PowerPC machines
+lshw: (PowerMac G4 is known to work).
+lshw:
+lshw:
+lshw: