summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2010-06-20 08:21:40 -0400
committer Erik Hanson <erik@slackbuilds.org>2010-06-20 15:20:25 -0500
commit0758cf33350dd7b5d97d7abd2942c686e24e0d4f (patch)
tree00ecaf48c9b23be2e1a660c5b4bc557f02ab44dc
parentb323e61539a92b31f1758c7d16f8103c7b7304a1 (diff)
downloadslackbuilds-0758cf33350dd7b5d97d7abd2942c686e24e0d4f.tar.gz
slackbuilds-0758cf33350dd7b5d97d7abd2942c686e24e0d4f.tar.xz
development/easygui: Updated for version 0.95.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--development/easygui/README2
-rw-r--r--development/easygui/easygui.SlackBuild18
-rw-r--r--development/easygui/easygui.info6
3 files changed, 15 insertions, 11 deletions
diff --git a/development/easygui/README b/development/easygui/README
index 0e7b2c558c..23da851bb9 100644
--- a/development/easygui/README
+++ b/development/easygui/README
@@ -18,3 +18,5 @@ easygui is there just to do very basic stuff. More elaborate stuff should
be done with more powerful tools. easygui is built on top of Tkinter.
A tutorial and more complete documentation can be found on easygui homepage.
+
+It can display all image-file formats supported by Python Imaging Library.
diff --git a/development/easygui/easygui.SlackBuild b/development/easygui/easygui.SlackBuild
index 81a03d9a70..a38ba416aa 100644
--- a/development/easygui/easygui.SlackBuild
+++ b/development/easygui/easygui.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for easygui
-# Copyright 2007-2009 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2007-2010 LukenShiro <lukenshiro@ngi.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=easygui
-VERSION=${VERSION:-0.93}
+VERSION=${VERSION:-0.95}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -56,11 +54,11 @@ else
fi
# directory for python packages
-PYTHONDIR="/usr/lib${LIBDIRSUFFIX}/python2.6/site-packages"
+PYTHONDIR=$(python -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
SAMPLEFILE="python_and_check_logo.gif"
DOCFILES="*.txt *.html"
-set -e # Exit on most errors
+set -e # Exit on most errors
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -70,11 +68,15 @@ mkdir -p $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/${PRGNAM}_${SRC_VERSION}.tar.gz
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
# install .py source file and sample file
+python ./setup.py build install --root=$PKG
mkdir -p $PKG/$PYTHONDIR
-install -m 0644 $PRGNAM.py $PKG/$PYTHONDIR
cp -a $SAMPLEFILE $PKG/$PYTHONDIR
# Copy documentation files
diff --git a/development/easygui/easygui.info b/development/easygui/easygui.info
index e1502d5378..041fb3ce8c 100644
--- a/development/easygui/easygui.info
+++ b/development/easygui/easygui.info
@@ -1,8 +1,8 @@
PRGNAM="easygui"
-VERSION="0.93"
+VERSION="0.95"
HOMEPAGE="http://easygui.sourceforge.net/"
-DOWNLOAD="http://easygui.sourceforge.net/current_version/easygui_v0.93.tar.gz"
-MD5SUM="764af8a7121751289284957133244867"
+DOWNLOAD="http://easygui.sourceforge.net/download/current_version/easygui_v0.95.tar.gz"
+MD5SUM="45aac917f91d1378b4e74027dbf21b75"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="LukenShiro"