summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author grissiom <chaos.proton@gmail.com>2010-06-20 08:23:47 -0400
committer Erik Hanson <erik@slackbuilds.org>2010-06-20 15:20:25 -0500
commit4f3b81b6d49934b07ac6f4e28d958e24b4264919 (patch)
tree33062e5cd6581fa224d36239f18780c185687665
parentac0d9da676605b5cfa839eea97f4170ae2a4a689 (diff)
downloadslackbuilds-4f3b81b6d49934b07ac6f4e28d958e24b4264919.tar.gz
slackbuilds-4f3b81b6d49934b07ac6f4e28d958e24b4264919.tar.xz
development/pylint: Updated for version 0.21.1.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--development/pylint/pylint.SlackBuild10
-rw-r--r--development/pylint/pylint.info6
-rw-r--r--development/pylint/slack-desc12
3 files changed, 12 insertions, 16 deletions
diff --git a/development/pylint/pylint.SlackBuild b/development/pylint/pylint.SlackBuild
index 0b2341d962..0a08ab18cb 100644
--- a/development/pylint/pylint.SlackBuild
+++ b/development/pylint/pylint.SlackBuild
@@ -5,11 +5,10 @@
# Written by Grissiom chaos.proton@gmail.com
PRGNAM=pylint
-VERSION=${VERSION:-0.18.0}
+VERSION=${VERSION:-0.21.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
@@ -24,7 +23,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-set -e # Exit on most errors
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -41,14 +40,11 @@ find . \
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p ${PKG}/usr/doc/$PRGNAM-$VERSION
rm -rf ${PKG}/usr/share
cp -a \
- PKG-INFO README ChangeLog COPYING TODO DEPENDS \
+ PKG-INFO README ChangeLog COPYING DEPENDS \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/development/pylint/pylint.info b/development/pylint/pylint.info
index 3a07303132..7aaf6bb745 100644
--- a/development/pylint/pylint.info
+++ b/development/pylint/pylint.info
@@ -1,8 +1,8 @@
PRGNAM="pylint"
-VERSION="0.18.0"
+VERSION="0.21.1"
HOMEPAGE="http://www.logilab.org/project/pylint"
-DOWNLOAD="http://ftp.logilab.org/pub/pylint/pylint-0.18.0.tar.gz"
-MD5SUM="2fb51eb37062aff094b104004ecd25a8"
+DOWNLOAD="http://ftp.logilab.org/pub/pylint/pylint-0.21.1.tar.gz"
+MD5SUM="70f82198cde208b9118e81a43f3c7d80"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="grissiom"
diff --git a/development/pylint/slack-desc b/development/pylint/slack-desc
index c11345dac2..aab8f65736 100644
--- a/development/pylint/slack-desc
+++ b/development/pylint/slack-desc
@@ -6,14 +6,14 @@
# leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
-pylint: pylint is a python code checker
+pylint: pylint (python code checker)
pylint:
-pylint: Pylint is a python tool that checks if a module satisfies a coding
-pylint: standard. Pylint can be seen as another PyChecker since nearly all
-pylint: tests you can do with PyChecker can also be done with Pylint. But
+pylint: Pylint is a python tool that checks if a module satisfies a coding
+pylint: standard. Pylint can be seen as another PyChecker since nearly all
+pylint: tests you can do with PyChecker can also be done with Pylint. But
pylint: Pylint offers some more features.
pylint:
-pylint: The big advantage with Pylint is that it is highly configurable,
-pylint: customizable, and you can easily write a small plugin to add a
+pylint: The big advantage with Pylint is that it is highly configurable,
+pylint: customizable, and you can easily write a small plugin to add a
pylint: personal feature.
pylint: