summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Nishant Limbachia <nishant@mnspace.net>2010-07-01 01:02:19 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-07-01 01:02:19 -0500
commit0260e20eb9bef240d7bd20338486484d571ed347 (patch)
tree7bacf7458cff1012d7fe83bffb542bb108db4b17
parent84928061228fe775b80c0e21b685215f956bb0d5 (diff)
downloadslackbuilds-0260e20eb9bef240d7bd20338486484d571ed347.tar.gz
slackbuilds-0260e20eb9bef240d7bd20338486484d571ed347.tar.xz
audio/python-audiotools: Added (CLI audio handling programs)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--audio/python-audiotools/README12
-rw-r--r--audio/python-audiotools/doinst.sh15
-rw-r--r--audio/python-audiotools/python-audiotools.SlackBuild94
-rw-r--r--audio/python-audiotools/python-audiotools.info10
-rw-r--r--audio/python-audiotools/slack-desc19
5 files changed, 150 insertions, 0 deletions
diff --git a/audio/python-audiotools/README b/audio/python-audiotools/README
new file mode 100644
index 0000000000..ce567b60ff
--- /dev/null
+++ b/audio/python-audiotools/README
@@ -0,0 +1,12 @@
+Python Audio Tools are a collection of audio handling programs which work
+from the command line. These include programs for CD extraction, track
+conversion from one audio format to another, track renaming and retagging,
+track identification, CD burning from tracks, and more. It supports
+internationalized track filenames and metadata using Unicode. It works
+with high-definition, multi-channel audio as well as CD-quality. Track
+conversion uses multiple CPUs or CPU cores if available to greatly speed
+the transcoding process. Track metadata can be retrieved from FreeDB or
+FreeDB-compatible servers.
+
+Supported audio formats are WAV, AIFF, Sun AU, FLAC, WavPack, MP3, MP2,
+Ogg Vorbis, Ogg Speex, Ogg FLAC, and M4A.
diff --git a/audio/python-audiotools/doinst.sh b/audio/python-audiotools/doinst.sh
new file mode 100644
index 0000000000..ee19f823a3
--- /dev/null
+++ b/audio/python-audiotools/doinst.sh
@@ -0,0 +1,15 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/audiotools.cfg.new
+
diff --git a/audio/python-audiotools/python-audiotools.SlackBuild b/audio/python-audiotools/python-audiotools.SlackBuild
new file mode 100644
index 0000000000..a3f3a62e43
--- /dev/null
+++ b/audio/python-audiotools/python-audiotools.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/sh
+
+# Slackware build script for Python Audio Tools
+# Home Page: http://audiotools.sourceforge.net/
+
+# Copyright (c) 2010, Nishant Limbachia, Hoffman Estates, IL, USA (nishant _AT_ mnspace _DOT_ net)
+# All rights reserved.
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+
+# 1. Redistributions of script must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
+# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM="python-audiotools"
+VERSION=${VERSION:-2.15}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="audiotools"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e # exit on most errors
+
+rm -rf $PKG $TMP/$SRCNAM-$VERSION
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/man/man{1,5}
+( cd docs; make install MAN_PATH=$PKG/usr/man )
+
+mv $PKG/etc/audiotools.cfg $PKG/etc/audiotools.cfg.new
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING INSTALL TODO docs/*.pdf $PKG/usr/doc/$PRGNAM-$VERSION
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/python-audiotools/python-audiotools.info b/audio/python-audiotools/python-audiotools.info
new file mode 100644
index 0000000000..12efce0990
--- /dev/null
+++ b/audio/python-audiotools/python-audiotools.info
@@ -0,0 +1,10 @@
+PRGNAM="python-audiotools"
+VERSION="2.15"
+HOMEPAGE="http://audiotools.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/audiotools/audiotools-2.15.tar.gz"
+MD5SUM="d3282d4c4298c809b61ea16c33a52241"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Nishant Limbachia"
+EMAIL="nishant@mnspace.net"
+APPROVED="rworkman"
diff --git a/audio/python-audiotools/slack-desc b/audio/python-audiotools/slack-desc
new file mode 100644
index 0000000000..609608330a
--- /dev/null
+++ b/audio/python-audiotools/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-audiotools: python-audiotools
+python-audiotools:
+python-audiotools: Python Audio Tools are a collection of audio handling programs
+python-audiotools: which work from the command line. These include programs for
+python-audiotools: CD extraction, track conversion from one audio format to another,
+python-audiotools: track renaming and retagging, track identification, CD burning
+python-audiotools: from tracks, and more.
+python-audiotools:
+python-audiotools: http://audiotools.sourceforge.net/
+python-audiotools:
+python-audiotools: