summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Mikko Värri <vmj@linuxbox.fi>2010-08-15 19:20:27 -0400
committer Erik Hanson <erik@slackbuilds.org>2010-08-15 20:53:43 -0500
commit744d212b725fa107bbd5965e16e3d8f011626f8b (patch)
treeaee2fd8e580241d09d04ed95465c51cd6e00bf64
parent39b4691ecd3e195b0e94e866413562e883493dce (diff)
downloadslackbuilds-744d212b725fa107bbd5965e16e3d8f011626f8b.tar.gz
slackbuilds-744d212b725fa107bbd5965e16e3d8f011626f8b.tar.xz
libraries/FormEncode: Updated for version 1.2.2.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--libraries/FormEncode/FormEncode.SlackBuild12
-rw-r--r--libraries/FormEncode/FormEncode.info10
-rw-r--r--libraries/FormEncode/README3
3 files changed, 13 insertions, 12 deletions
diff --git a/libraries/FormEncode/FormEncode.SlackBuild b/libraries/FormEncode/FormEncode.SlackBuild
index c0e6df4e61..7508cb0f2c 100644
--- a/libraries/FormEncode/FormEncode.SlackBuild
+++ b/libraries/FormEncode/FormEncode.SlackBuild
@@ -2,20 +2,18 @@
# Slackware build script for FormEncode
-# Written by Mikko Varri (vmj@linuxbox.fi)
+# Written by Mikko Värri (vmj@linuxbox.fi)
# Public domain
PRGNAM=FormEncode
-VERSION=${VERSION:-1.2}
+VERSION=${VERSION:-1.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -41,9 +39,11 @@ find . \
-exec chmod 644 {} \;
python setup.py install --root=$PKG
+./regen-docs || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a docs/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
+cp -a docs/_build/* $PKG/usr/doc/$PRGNAM-$VERSION/html || \
+ cp -a docs $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/FormEncode/FormEncode.info b/libraries/FormEncode/FormEncode.info
index 1b6767b669..c15e11eaa0 100644
--- a/libraries/FormEncode/FormEncode.info
+++ b/libraries/FormEncode/FormEncode.info
@@ -1,10 +1,10 @@
PRGNAM="FormEncode"
-VERSION="1.2"
+VERSION="1.2.2"
HOMEPAGE="http://FormEncode.org/"
-DOWNLOAD="http://pypi.python.org/packages/source/F/FormEncode/FormEncode-1.2.tar.gz"
-MD5SUM="da9d30ad0115ed8de86dc3b796899b41"
+DOWNLOAD="http://pypi.python.org/packages/source/F/FormEncode/FormEncode-1.2.2.tar.gz"
+MD5SUM="da23d54af521d1feab12b4caf30e3111"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="Mikko Varri"
+MAINTAINER="Mikko Värri"
EMAIL="vmj@linuxbox.fi"
-APPROVED="rworkman"
+APPROVED="dsomero"
diff --git a/libraries/FormEncode/README b/libraries/FormEncode/README
index d029a4fbb0..ce27d9ad9e 100644
--- a/libraries/FormEncode/README
+++ b/libraries/FormEncode/README
@@ -5,6 +5,7 @@ declarative form of defining the validation, and decoupled processes
for filling and generating forms.
NOTE: To build this package, setuptools needs to be installed
-(available at SlackBuilds.org as "pysetuptools").
+(available at SlackBuilds.org as "pysetuptools"). Also, Sphinx, if
+installed, is used to generate the docs.
NOTE: Running the test suite requires nose.