summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author David Woodfall <dave@dawoodfall.net>2010-08-15 18:20:19 -0400
committer Erik Hanson <erik@slackbuilds.org>2010-08-15 20:53:42 -0500
commite44543da8ad3aae93a72bb7b4d50e8826ecb8ec4 (patch)
treeedacaa17633111f2e8919400eb54942182920123
parent8f54bc60f239bf7f60ac75d7099dcc871b429998 (diff)
downloadslackbuilds-e44543da8ad3aae93a72bb7b4d50e8826ecb8ec4.tar.gz
slackbuilds-e44543da8ad3aae93a72bb7b4d50e8826ecb8ec4.tar.xz
libraries/python-elementtree: Added (Python library wrapper for XML)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--libraries/python-elementtree/README7
-rw-r--r--libraries/python-elementtree/python-elementtree.SlackBuild89
-rw-r--r--libraries/python-elementtree/python-elementtree.info10
-rw-r--r--libraries/python-elementtree/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/libraries/python-elementtree/README b/libraries/python-elementtree/README
new file mode 100644
index 0000000000..e0c761f808
--- /dev/null
+++ b/libraries/python-elementtree/README
@@ -0,0 +1,7 @@
+The Element type is a simple but flexible container object, designed
+to store hierarchical data structures, such as simplified XML
+infosets, in memory. The element type can be described as a cross
+between a Python list and a Python dictionary.
+
+The ElementTree wrapper type adds code to load XML files as trees of
+Element objects, and save them back again.
diff --git a/libraries/python-elementtree/python-elementtree.SlackBuild b/libraries/python-elementtree/python-elementtree.SlackBuild
new file mode 100644
index 0000000000..fead173deb
--- /dev/null
+++ b/libraries/python-elementtree/python-elementtree.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for elementtree
+# Copyright 2010 David Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=elementtree
+PRGNAM=python-$SRCNAM
+VERSION=${VERSION:-1.2.7-20070827-preview}
+ARCVERSION=$VERSION
+VERSION=$(echo $VERSION | tr - _)
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$ARCVERSION
+unzip $CWD/$SRCNAM-$ARCVERSION.zip
+cd $SRCNAM-$ARCVERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-elementtree/python-elementtree.info b/libraries/python-elementtree/python-elementtree.info
new file mode 100644
index 0000000000..1b8beab3c0
--- /dev/null
+++ b/libraries/python-elementtree/python-elementtree.info
@@ -0,0 +1,10 @@
+PRGNAM="python-elementtree"
+VERSION="1.2.7_20070827_preview"
+HOMEPAGE="http://effbot.org/zone/element-index.htm"
+DOWNLOAD="http://effbot.org/media/downloads/elementtree-1.2.7-20070827-preview.zip"
+MD5SUM="30e2fe5edd143f347e03a8baf5d60f8a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
+APPROVED="dsomero"
diff --git a/libraries/python-elementtree/slack-desc b/libraries/python-elementtree/slack-desc
new file mode 100644
index 0000000000..a23f6dc591
--- /dev/null
+++ b/libraries/python-elementtree/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-elementtree: elementtree ( Python library wrapper for XML )
+python-elementtree:
+python-elementtree: The Element type is a simple but flexible container object, designed
+python-elementtree: to store hierarchical data structures, such as simplified XML
+python-elementtree: infosets, in memory. The element type can be described as a cross
+python-elementtree: between a Python list and a Python dictionary.
+python-elementtree:
+python-elementtree: The ElementTree wrapper type adds code to load XML files as trees of
+python-elementtree: Element objects, and save them back again.
+python-elementtree:
+python-elementtree: Homepage: http://effbot.org/zone/element-index.htm