summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2012-05-05 12:21:55 -0400
committer Erik Hanson <erik@slackbuilds.org>2012-05-07 12:18:09 -0500
commit6c4fa6121d5ce29ca2095fd4e071248f28df2e69 (patch)
tree8722c344cfe743143b4c5a7f40f00922b7d98747
parent2d41f5ec0ff540a6b326d2d06b38b7fc70aef5c0 (diff)
downloadslackbuilds-6c4fa6121d5ce29ca2095fd4e071248f28df2e69.tar.gz
slackbuilds-6c4fa6121d5ce29ca2095fd4e071248f28df2e69.tar.xz
python/python-magic: Added (uses ctypes to access the libmagic)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--python/python-magic/README5
-rw-r--r--python/python-magic/python-magic.SlackBuild53
-rw-r--r--python/python-magic/python-magic.info10
-rw-r--r--python/python-magic/slack-desc19
4 files changed, 87 insertions, 0 deletions
diff --git a/python/python-magic/README b/python/python-magic/README
new file mode 100644
index 0000000000..69a698c594
--- /dev/null
+++ b/python/python-magic/README
@@ -0,0 +1,5 @@
+This module uses ctypes to access the libmagic file type identification
+library. It makes use of the local magic database and supports both textual
+and MIME-type output.
+
+Python-magic requires distribute.
diff --git a/python/python-magic/python-magic.SlackBuild b/python/python-magic/python-magic.SlackBuild
new file mode 100644
index 0000000000..b57603b3aa
--- /dev/null
+++ b/python/python-magic/python-magic.SlackBuild
@@ -0,0 +1,53 @@
+#!/bin/sh
+
+# Slackware build script for python-magic
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=python-magic
+VERSION=${VERSION:-0.4.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-magic/python-magic.info b/python/python-magic/python-magic.info
new file mode 100644
index 0000000000..bfc0f28ca5
--- /dev/null
+++ b/python/python-magic/python-magic.info
@@ -0,0 +1,10 @@
+PRGNAM="python-magic"
+VERSION="0.4.2"
+HOMEPAGE="https://github.com/ahupp/python-magic"
+DOWNLOAD="http://pypi.python.org/packages/source/p/python-magic/python-magic-0.4.2.tar.gz"
+MD5SUM="7266bf9d79ba2dc8ecc85764aeb45afd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="dsomero"
diff --git a/python/python-magic/slack-desc b/python/python-magic/slack-desc
new file mode 100644
index 0000000000..b493def9f0
--- /dev/null
+++ b/python/python-magic/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-magic: python-magic (uses ctypes to access the libmagic)
+python-magic:
+python-magic: This module uses ctypes to access the libmagic file type
+python-magic: identification library. It makes use of the local magic database and
+python-magic: supports both textual and MIME-type output.
+python-magic:
+python-magic: Homepage: https://github.com/ahupp/python-magic
+python-magic:
+python-magic:
+python-magic:
+python-magic: