summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Charles E. Kauffman <molbolom@gmail.com>2012-05-05 12:14:29 -0400
committer Erik Hanson <erik@slackbuilds.org>2012-05-07 12:18:07 -0500
commitc9cc80e4c06c14e4f6e9f9324ddbcb7c3ab3d19d (patch)
tree87088b3f869aeeddcb57c91801e2b9b74808817b
parent6fdd093a3292a7ecbd91bda28554fa5bfc1906f2 (diff)
downloadslackbuilds-c9cc80e4c06c14e4f6e9f9324ddbcb7c3ab3d19d.tar.gz
slackbuilds-c9cc80e4c06c14e4f6e9f9324ddbcb7c3ab3d19d.tar.xz
desktop/echinus: Added (lightweight tiling window manager)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--desktop/echinus/README5
-rw-r--r--desktop/echinus/echinus.SlackBuild88
-rw-r--r--desktop/echinus/echinus.info10
-rw-r--r--desktop/echinus/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/desktop/echinus/README b/desktop/echinus/README
new file mode 100644
index 0000000000..607b6ac13b
--- /dev/null
+++ b/desktop/echinus/README
@@ -0,0 +1,5 @@
+Echinus is a simple and lightweight tiling window manager for x similar
+to dwm except it can have windows with close, minimize, and maximize
+buttons and has a simple config file.
+
+Read the README for customizing options.
diff --git a/desktop/echinus/echinus.SlackBuild b/desktop/echinus/echinus.SlackBuild
new file mode 100644
index 0000000000..3d41ebadeb
--- /dev/null
+++ b/desktop/echinus/echinus.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+
+# Slackware build script for <appname>
+
+# Written by Charles E. Kauffman gahlgwogi@lycos.com
+# Modified from Tom Canich's slackbuild for dwm.
+
+PRGNAM=echinus
+VERSION=${VERSION:-0.4.9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Makefile specific variables.
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sed -i "s;-Os;$SLKCFLAGS ;" config.mk
+sed -i "s;.pixmap: ;.pixmap: \/usr\/share\/echinus\/;" echinusrc
+sed -i "s/DOCPREFIX}\/echinus/DOCPREFIX}\/echinus-$VERSION/" Makefile
+
+make install \
+ PREFIX=/usr \
+ DOCPREFIX=/usr/doc \
+ CONFPREFIX=/usr/share \
+ MANPREFIX=/usr/man \
+ X11INC=/usr/include/X11 \
+ X11LIB=/usr/lib${LIBDIRSUFFIX}/X11 \
+ CONF=/share/echinus \
+ DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/echinus/echinus.info b/desktop/echinus/echinus.info
new file mode 100644
index 0000000000..2b907ab94d
--- /dev/null
+++ b/desktop/echinus/echinus.info
@@ -0,0 +1,10 @@
+PRGNAM="echinus"
+VERSION="0.4.9"
+HOMEPAGE="http://plhk.ru"
+DOWNLOAD="http://plhk.ru/static/echinus/echinus-0.4.9.tar.gz"
+MD5SUM="8e17f3973060121847050b74a1bf000d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Charles E. Kauffman"
+EMAIL="molbolom@gmail.com"
+APPROVED="dsomero"
diff --git a/desktop/echinus/slack-desc b/desktop/echinus/slack-desc
new file mode 100644
index 0000000000..4c1770489e
--- /dev/null
+++ b/desktop/echinus/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+echinus: echinus (lightweight tiling window manager)
+echinus:
+echinus: echinus is a simple and lightweight tiling window manager for x
+echinus: similarto dwm except it can have windows with close, minimize,
+echinus: and maximizebuttons and has a simple config file.
+echinus:
+echinus: Homepage: http://plhk.ru
+echinus:
+echinus:
+echinus:
+echinus: