summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2012-08-01 08:34:54 -0300
committer Robby Workman <rworkman@slackbuilds.org>2012-08-14 22:30:33 -0500
commit7db66fdb9bc2b339a63ef3f847d744bcbc7582af (patch)
tree95d04ee0783e0282f9ea8ebabef51370e8db7960
parentc8bf3c668c3bf7b13f012ca9ad214b7f8fde5c13 (diff)
downloadslackbuilds-7db66fdb9bc2b339a63ef3f847d744bcbc7582af.tar.gz
slackbuilds-7db66fdb9bc2b339a63ef3f847d744bcbc7582af.tar.xz
games/meandmyshadow: Patched for gcc-4.7.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--games/meandmyshadow/gcc-4.7.patch14
-rw-r--r--games/meandmyshadow/meandmyshadow.SlackBuild5
-rw-r--r--games/meandmyshadow/meandmyshadow.info2
3 files changed, 19 insertions, 2 deletions
diff --git a/games/meandmyshadow/gcc-4.7.patch b/games/meandmyshadow/gcc-4.7.patch
new file mode 100644
index 0000000000..3298a088f0
--- /dev/null
+++ b/games/meandmyshadow/gcc-4.7.patch
@@ -0,0 +1,14 @@
+diff -Naur meandmyshadow-0.3.orig/src/TreeStorageNode.cpp meandmyshadow-0.3/src/TreeStorageNode.cpp
+--- meandmyshadow-0.3.orig/src/TreeStorageNode.cpp 2012-02-07 18:19:03.000000000 +0000
++++ meandmyshadow-0.3/src/TreeStorageNode.cpp 2012-07-11 02:17:49.188110565 +0000
+@@ -17,6 +17,10 @@
+ **
+ ****************************************************************************/
+
++#ifndef WIN32
++#include <stdint.h>
++#include <unistd.h>
++#endif
+ #include "TreeStorageNode.h"
+ #include "MD5.h"
+ #include <string.h>
diff --git a/games/meandmyshadow/meandmyshadow.SlackBuild b/games/meandmyshadow/meandmyshadow.SlackBuild
index 3f732b8519..63bb8b3bcf 100644
--- a/games/meandmyshadow/meandmyshadow.SlackBuild
+++ b/games/meandmyshadow/meandmyshadow.SlackBuild
@@ -6,7 +6,7 @@
PRGNAM=meandmyshadow
VERSION=${VERSION:-0.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -57,6 +57,9 @@ sed -i -e '/^Version/d' -e 's|;Game;|;|' meandmyshadow.desktop
# SLKCFLAGS are respected.
sed -i "s|-Wall -g|& $SLKCFLAGS|" CMakeLists.txt
+# From upstream. Fix for building with gcc 4.7.x.
+patch -p1 < $CWD/gcc-4.7.patch
+
mkdir -p build
cd build
cmake -G "Unix Makefiles" \
diff --git a/games/meandmyshadow/meandmyshadow.info b/games/meandmyshadow/meandmyshadow.info
index 098f79ca90..32c3aead23 100644
--- a/games/meandmyshadow/meandmyshadow.info
+++ b/games/meandmyshadow/meandmyshadow.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="dsomero"
+APPROVED="dsomero,Niels Horn"