summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author klaatu <klaatu@member.fsf.org>2013-01-07 20:01:30 +0100
committer dsomero <xgizzmo@slackbuilds.org>2013-01-09 18:52:25 -0500
commit6fc906218a26638e80d67d6cd66b97dd0b6be4c0 (patch)
treefc16e64ee7ef6e0d5bbcb0a862a360663100547c
parentade776e429e2dcc038964e1d964c9b67b009fad3 (diff)
downloadslackbuilds-6fc906218a26638e80d67d6cd66b97dd0b6be4c0.tar.gz
slackbuilds-6fc906218a26638e80d67d6cd66b97dd0b6be4c0.tar.xz
multimedia/flowblade: Added (non-linear video editor).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--multimedia/flowblade/README18
-rw-r--r--multimedia/flowblade/doinst.sh13
-rw-r--r--multimedia/flowblade/flowblade.SlackBuild91
-rw-r--r--multimedia/flowblade/flowblade.info10
-rw-r--r--multimedia/flowblade/slack-desc19
5 files changed, 151 insertions, 0 deletions
diff --git a/multimedia/flowblade/README b/multimedia/flowblade/README
new file mode 100644
index 0000000000..1fe2269746
--- /dev/null
+++ b/multimedia/flowblade/README
@@ -0,0 +1,18 @@
+Flowblade Movie Editor is a multitrack non-linear video editor for
+Linux released under GPL 3 license.
+
+It is designed to provide a fast, precise and as-simple-as-possible
+editing experience.
+
+It employs film style editing paradigm in which clips are
+usually automatically placed tightly after the previous clip - or
+between two existing clips - when they are inserted on the
+timeline. Edits are fine tuned by trimming in and out points of clips,
+or by cutting and deleting parts of clips. Film style editing is
+faster for creating programs with mostly straight cuts and audio
+splits, but may be slower when programs contain complex composites
+unless correct work flow is followed.
+
+It provides powerful tools to mix and filter video and audio.
+
+Optional recommended dependencies are swh-plugins and calf.
diff --git a/multimedia/flowblade/doinst.sh b/multimedia/flowblade/doinst.sh
new file mode 100644
index 0000000000..9424ce43ff
--- /dev/null
+++ b/multimedia/flowblade/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/multimedia/flowblade/flowblade.SlackBuild b/multimedia/flowblade/flowblade.SlackBuild
new file mode 100644
index 0000000000..5e3365916b
--- /dev/null
+++ b/multimedia/flowblade/flowblade.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for flowblade
+# Copyright 2013 klaatu @member.fsf.org
+# GNU All-Permissive License
+# Copying and distribution of this file, with or without modification,
+# are permitted in any medium without royalty provided the copyright
+# notice and this notice are preserved. This file is offered as-is,
+# without any warranty.
+
+PRGNAM=flowblade
+VERSION=${VERSION:-0.8.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+PYTHONDIR=$(python -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# fix a path in the main script
+sed -i "s|/usr/share/pyshared|$PYTHONDIR|" $PKG/usr/bin/$PRGNAM
+
+# remove unnecessary files
+rm -fr $PKG/usr/lib/mime
+rmdir $PKG/usr/lib || true
+
+# stripper
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# man
+mkdir -p $PKG/usr/man/man1/
+mv $PKG/usr/share/man/man1/$PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
+rmdir $PKG/usr/share/man/man1 $PKG/usr/share/man
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+# doc
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ PKG-INFO README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/flowblade/flowblade.info b/multimedia/flowblade/flowblade.info
new file mode 100644
index 0000000000..886c4e9f0c
--- /dev/null
+++ b/multimedia/flowblade/flowblade.info
@@ -0,0 +1,10 @@
+PRGNAM="flowblade"
+VERSION="0.8.0"
+HOMEPAGE="https://code.google.com/p/flowblade/"
+DOWNLOAD="https://flowblade.googlecode.com/files/flowblade-0.8.0.tar.gz"
+MD5SUM="77dc12495018305b30bb6d0dc675b910"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="cairomm ffmpeg frei0r gnome-python ladspa_sdk mlt"
+MAINTAINER="klaatu"
+EMAIL="klaatu@member.fsf.org"
diff --git a/multimedia/flowblade/slack-desc b/multimedia/flowblade/slack-desc
new file mode 100644
index 0000000000..3dce6eeae7
--- /dev/null
+++ b/multimedia/flowblade/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+flowblade: flowblade (non-linear video editor)
+flowblade:
+flowblade: Flowblade employs film style editing paradigm in which clips are
+flowblade: usually automatically placed tightly after the previous clip - or
+flowblade: between two existing clips - when they are inserted on the timeline.
+flowblade: It is efficient, effective, and includes powerful tools to mix,
+flowblade: filter, and affect video and audio.
+flowblade:
+flowblade: https://code.google.com/p/flowblade/
+flowblade:
+flowblade: