summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2013-03-16 10:03:39 -0400
committer dsomero <xgizzmo@slackbuilds.org>2013-03-22 07:16:48 -0400
commit6a3c5091a4dbd5fe56f55601822dcd3164d4f10f (patch)
treeb71a4432730ef4bb746cbba3513d76588ffa5271
parent4d55ce925efc264abd4a780d21d9a117ac6a1a21 (diff)
downloadslackbuilds-6a3c5091a4dbd5fe56f55601822dcd3164d4f10f.tar.gz
slackbuilds-6a3c5091a4dbd5fe56f55601822dcd3164d4f10f.tar.xz
python/simplejson: Updated for version 3.1.0.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--python/simplejson/README11
-rw-r--r--python/simplejson/simplejson.SlackBuild34
-rw-r--r--python/simplejson/simplejson.info10
-rw-r--r--python/simplejson/slack-desc18
4 files changed, 48 insertions, 25 deletions
diff --git a/python/simplejson/README b/python/simplejson/README
index 8abe9b51e7..d780eb9722 100644
--- a/python/simplejson/README
+++ b/python/simplejson/README
@@ -1,5 +1,6 @@
-Simple, fast, extensible JSON encoder/decoder for Python.
-simplejson is a simple, fast, complete, correct and extensible
-JSON <http://json.org> encoder and decoder for Python 2.4+.
-It is pure Python code, but includes an optional C extension
-for a serious speed boost.
+Simplejson is a simple, fast, complete, correct and extensible JSON
+<http://json.org> encoder and decoder for Python 2.5+ and Python 3.3+. It is
+pure Python code with no dependencies, but includes an optional C extension for
+a serious speed boost.
+
+Optional documentation can be built if Sphinx and Pygments are installed.
diff --git a/python/simplejson/simplejson.SlackBuild b/python/simplejson/simplejson.SlackBuild
index 0f645b0f22..00e28721e9 100644
--- a/python/simplejson/simplejson.SlackBuild
+++ b/python/simplejson/simplejson.SlackBuild
@@ -1,18 +1,37 @@
#!/bin/sh
+
# Slackware build script for simplejson
+
# Written by Larry Hajali <larryhaja[at]gail[dot]com>
+# Copyright 2009-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=simplejson
-VERSION=${VERSION:-2.1.6}
+VERSION=${VERSION:-3.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -37,17 +56,20 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Lets use the system setuptools rather then ez_setup.
-rm -f ez_setup.py
+# Make documents if Sphinx and Pygments are installed.
+if $(python -c 'import sphinx.pygments_styles' 2>/dev/null); then
+ python scripts/make_docs.py
+fi
python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a {CHANGES,LICENSE}.txt README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+[ -d docs ] && (rm -f docs/objects.inv; cp -ar docs $PKG/usr/doc/$PRGNAM-$VERSION)
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/python/simplejson/simplejson.info b/python/simplejson/simplejson.info
index 7dcb4e48ad..0cf7cf1855 100644
--- a/python/simplejson/simplejson.info
+++ b/python/simplejson/simplejson.info
@@ -1,10 +1,10 @@
PRGNAM="simplejson"
-VERSION="2.1.6"
-HOMEPAGE="http://undefined.org/python/#simplejson"
-DOWNLOAD="http://pypi.python.org/packages/source/s/simplejson/simplejson-2.1.6.tar.gz"
-MD5SUM="2f8351f6e6fe7ef25744805dfa56c0d5"
+VERSION="3.1.0"
+HOMEPAGE="https://github.com/simplejson/simplejson"
+DOWNLOAD="http://pypi.python.org/packages/source/s/simplejson/simplejson-3.1.0.tar.gz"
+MD5SUM="71df0076d4a35d29bfea530cb8226c26"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pysetuptools"
+REQUIRES=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/simplejson/slack-desc b/python/simplejson/slack-desc
index f31e3137ca..74fc847921 100644
--- a/python/simplejson/slack-desc
+++ b/python/simplejson/slack-desc
@@ -1,19 +1,19 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
simplejson: simplejson (extensible JSON encoder and decoder for Python)
simplejson:
simplejson: Simplejson is a simple, fast, complete, correct and extensible JSON
-simplejson: encoder and decoder for Python 2.3+. It is pure Python code, but
-simplejson: includes an optional C extension for a serious speed boost.
-simplejson:
-simplejson: Homepage: http://undefined.org/python/#simplejson
+simplejson: <http://json.org> encoder and decoder for Python 2.5+ and Python 3.3+.
+simplejson: It is pure Python code with no dependencies, but includes an optional
+simplejson: C extension for a serious speed boost.
simplejson:
+simplejson: Homepage: https://github.com/simplejson/simplejson
simplejson:
simplejson:
simplejson: