summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-09-30 23:25:03 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-01 07:28:39 +0700
commit940845edca4a833c6f2d5c891aa311732610d693 (patch)
treea0b386706e1b5b286bce43fab9d2a78c9c4dfb2b
parent6f001b162050650fe19160c115b864b348d09172 (diff)
downloadslackbuilds-940845edca4a833c6f2d5c891aa311732610d693.tar.gz
slackbuilds-940845edca4a833c6f2d5c891aa311732610d693.tar.xz
python/jsonschema: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/jsonschema/jsonschema.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/python/jsonschema/jsonschema.SlackBuild b/python/jsonschema/jsonschema.SlackBuild
index c6b28d5917..4a2eaf981c 100644
--- a/python/jsonschema/jsonschema.SlackBuild
+++ b/python/jsonschema/jsonschema.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jsonschema
-# Copyright 2014-2015 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG