summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-13 13:43:58 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-15 07:09:48 +0700
commit0fa1762f09458a557659f0688017b5ce9ad455d7 (patch)
treec14cb5f42e420a197fcb28bce76e704f9af78b4f
parente34c0a99d0da4c70ce0092ee2bf5d7b54c12ebdd (diff)
downloadslackbuilds-0fa1762f09458a557659f0688017b5ce9ad455d7.tar.gz
slackbuilds-0fa1762f09458a557659f0688017b5ce9ad455d7.tar.xz
python/piprot: Updated for version 0.9.7.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/piprot/piprot.SlackBuild14
-rw-r--r--python/piprot/piprot.info6
2 files changed, 10 insertions, 10 deletions
diff --git a/python/piprot/piprot.SlackBuild b/python/piprot/piprot.SlackBuild
index 25af95b066..7a45468c7f 100644
--- a/python/piprot/piprot.SlackBuild
+++ b/python/piprot/piprot.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for piprot
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=piprot
-VERSION=${VERSION:-0.8.2}
+VERSION=${VERSION:-0.9.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -75,7 +75,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a HISTORY.rst LICENCE.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENCE.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/piprot/piprot.info b/python/piprot/piprot.info
index cd9137398a..1005832422 100644
--- a/python/piprot/piprot.info
+++ b/python/piprot/piprot.info
@@ -1,8 +1,8 @@
PRGNAM="piprot"
-VERSION="0.8.2"
+VERSION="0.9.7"
HOMEPAGE="https://github.com/sesh/piprot"
-DOWNLOAD="https://pypi.python.org/packages/source/p/piprot/piprot-0.8.2.tar.gz"
-MD5SUM="4b2b9db047c2299e9ffd926085b78098"
+DOWNLOAD="https://pypi.python.org/packages/f2/0f/a14f16e6c03ecd11805408afdd7830835b7c4509c22c6ce2027c4a677d72/piprot-0.9.7.tar.gz"
+MD5SUM="e8ce3c5469538ab56b50cd21e748a3db"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="six requests-futures"