summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-26 20:46:18 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-29 06:58:15 +0700
commite6c09cb5f5f23508ba520c2c9fa664555f29914b (patch)
tree406a11c9bea054154cfface0583e29f751f31d3f
parent6cadae939882076f1f6100ee52ebf2beed439eec (diff)
downloadslackbuilds-e6c09cb5f5f23508ba520c2c9fa664555f29914b.tar.gz
slackbuilds-e6c09cb5f5f23508ba520c2c9fa664555f29914b.tar.xz
libraries/pyjf3: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--libraries/pyjf3/pyjf3.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/libraries/pyjf3/pyjf3.SlackBuild b/libraries/pyjf3/pyjf3.SlackBuild
index 8e1ee29b63..f4d9aafcc2 100644
--- a/libraries/pyjf3/pyjf3.SlackBuild
+++ b/libraries/pyjf3/pyjf3.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyjf3
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python3 setup.py install --root=$PKG