summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-29 09:02:07 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-29 09:02:07 +0700
commit8485056130056bbca82c3635116c9acca237776e (patch)
tree72b33d74f631accb5abdde1c4e3d71c0e458a34e
parent80f0c2267130ed0b448985919a71fcf11b1be356 (diff)
downloadslackbuilds-8485056130056bbca82c3635116c9acca237776e.tar.gz
slackbuilds-8485056130056bbca82c3635116c9acca237776e.tar.xz
libraries/python-efl: Added (Python bindings to the EFL).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/python-efl/README6
-rw-r--r--libraries/python-efl/python-efl.SlackBuild85
-rw-r--r--libraries/python-efl/python-efl.info10
-rw-r--r--libraries/python-efl/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/libraries/python-efl/README b/libraries/python-efl/README
new file mode 100644
index 0000000000..eada94c6b1
--- /dev/null
+++ b/libraries/python-efl/README
@@ -0,0 +1,6 @@
+Python bindings for Elementary.
+
+This package supersedes the following packages:
+ python-e_dbus python-elementary python-emotion python-ethumb python-evas
+
+Please remove the above packages before installing this one.
diff --git a/libraries/python-efl/python-efl.SlackBuild b/libraries/python-efl/python-efl.SlackBuild
new file mode 100644
index 0000000000..891e8f4839
--- /dev/null
+++ b/libraries/python-efl/python-efl.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+# Slackware build script for python-efl
+# Erik Falor | Logan, UT | ewfalor@gmail.com
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version, with the following exception:
+# the text of the GPL license may be omitted.
+
+# This program is distributed in the hope that it will be useful, but
+# without any warranty; without even the implied warranty of
+# merchantability or fitness for a particular purpose. Compiling,
+# interpreting, executing or merely reading the text of the program
+# may result in lapses of consciousness and/or very being, up to and
+# including the end of all existence and the Universe as we know it.
+# See the GNU General Public License for more details.
+
+# You may have received a copy of the GNU General Public License along
+# with this program (most likely, a file named COPYING). If not, see
+# <http://www.gnu.org/licenses/>.
+
+PRGNAM=python-efl
+VERSION=${VERSION:-1.19.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING COPYING.LESSER ChangeLog INSTALL README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-efl/python-efl.info b/libraries/python-efl/python-efl.info
new file mode 100644
index 0000000000..fd202861b0
--- /dev/null
+++ b/libraries/python-efl/python-efl.info
@@ -0,0 +1,10 @@
+PRGNAM="python-efl"
+VERSION="1.19.0"
+HOMEPAGE="https://www.enlightenment.org/"
+DOWNLOAD="https://download.enlightenment.org/rel/bindings/python/python-efl-1.19.0.tar.gz"
+MD5SUM="bef03c86ee5e590d8ef94dc760cef1fe "
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="efl"
+MAINTAINER="Erik Falor"
+EMAIL="ewfalor@gmail.com"
diff --git a/libraries/python-efl/slack-desc b/libraries/python-efl/slack-desc
new file mode 100644
index 0000000000..4ff9d323a8
--- /dev/null
+++ b/libraries/python-efl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-efl: python-efl (Python bindings to the EFL)
+python-efl:
+python-efl: Python bindings for EFL.
+python-efl:
+python-efl: https://www.enlightenment.org/
+python-efl:
+python-efl:
+python-efl:
+python-efl:
+python-efl:
+python-efl: