summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2018-09-04 01:06:16 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-09-08 08:37:47 +0700
commit80528372e9391419d046033f8460b8c4419d333e (patch)
tree44b3ed54b365b7fd68ffdac3d82ecea5b6f70181
parent4305c836939f8eb0b7f83489c04e98849a73b834 (diff)
downloadslackbuilds-80528372e9391419d046033f8460b8c4419d333e.tar.gz
slackbuilds-80528372e9391419d046033f8460b8c4419d333e.tar.xz
office/zathura: Disable synctex until textlive is fixed.
Signed-off-by: B. Watson <yalhcru@gmail.com>
-rw-r--r--office/zathura/README3
-rw-r--r--office/zathura/zathura.SlackBuild31
2 files changed, 22 insertions, 12 deletions
diff --git a/office/zathura/README b/office/zathura/README
index 6602caff9d..189dcf21ba 100644
--- a/office/zathura/README
+++ b/office/zathura/README
@@ -16,8 +16,5 @@ When upgrading zathura, you must rebuild all its plugins
against the new version of zathura, even if the version numbers
are the same.
-texlive is an optional dependency, required for synctex support. If you
-don't know what this is, you almost certainly don't need it.
-
zathura 0.3.8 is the last possible update for Slackware
14.2. Newer versions would require a newer gtk+3.
diff --git a/office/zathura/zathura.SlackBuild b/office/zathura/zathura.SlackBuild
index 6cbcee77e2..28e06b3447 100644
--- a/office/zathura/zathura.SlackBuild
+++ b/office/zathura/zathura.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for zathura
-# Copyright 2010 Binh Nguyen <binhnguyen@fastmail.fm>
+# Copyright 2010 Binh Nguyen <email removed>
+# Copyright 2018 B. Watson <yalhcru@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,6 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20180903 bkw:
+# - Disable building with synctex, since it currently doesn't work due
+# to a bug in the texlive package. Will be re-enabled when the texlive
+# issue is fixed.
+# - Really get rid of color output from the Makefile. I know it's cute,
+# but it confuses less when redirecting to a file.
+
# 20180102 bkw:
# - Updated for v0.3.8. Have to do some fudging to get it to build with
# Slack 14.2's older glib2: upstream claims they need 2.50, but the
@@ -112,11 +120,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# Work around a bug in Slackware's ghostscript.
# http://bugs.ghostscript.com/show_bug.cgi?id=692891
@@ -147,15 +152,23 @@ find -L . \
patch -p1 < $CWD/dlopen_hack.diff
sed -i "s/-pedantic/$SLKCFLAGS/" config.mk
-sed -i '/-fdiagnostics-color/d' colors.mk
sed -i '/--dependency-file/d' Makefile
# 20170711 bkw: git tarballs don't include prebuilt man pages, and I do NOT
# want Sphinx and its 15+ deps as a dep for this build. So:
cp -r $CWD/man doc/_build
-make LIBDIR=/usr/lib$LIBDIRSUFFIX GLIB_VERSION_CHECK=0
-make install LIBDIR=/usr/lib$LIBDIRSUFFIX MANPREFIX=/usr/man DESTDIR=$PKG RSTTOMAN=""
+make \
+ LIBDIR=/usr/lib$LIBDIRSUFFIX \
+ MANPREFIX=/usr/man \
+ DESTDIR=$PKG \
+ RSTTOMAN="" \
+ COLOR=0 \
+ GLIB_VERSION_CHECK=0 \
+ WITH_SYNCTEX=0 \
+ all \
+ install
+
gzip $PKG/usr/man/man?/*.?
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION