summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2020-09-26 06:47:14 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-09-26 16:10:55 +0700
commit587a44bd8168c7a82f4fc4fe7a46d1e35fec23da (patch)
tree405b82cf48f6e0e3219eec0b8bfa85b91bd796cd
parent187eea753b4a4b7687a95b00a99b55e4fa59149a (diff)
downloadslackbuilds-587a44bd8168c7a82f4fc4fe7a46d1e35fec23da.tar.gz
slackbuilds-587a44bd8168c7a82f4fc4fe7a46d1e35fec23da.tar.xz
libraries/Impacket: Updated for version 0.9.21.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/Impacket/Impacket.SlackBuild16
-rw-r--r--libraries/Impacket/Impacket.info10
-rw-r--r--libraries/Impacket/README8
-rw-r--r--libraries/Impacket/slack-desc2
4 files changed, 20 insertions, 16 deletions
diff --git a/libraries/Impacket/Impacket.SlackBuild b/libraries/Impacket/Impacket.SlackBuild
index 1d22002ffa..3f5ab040fb 100644
--- a/libraries/Impacket/Impacket.SlackBuild
+++ b/libraries/Impacket/Impacket.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for Impacket.
# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
-# Copyright 2015-2016, 2018 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2020, Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,7 @@
PRGNAM=Impacket
SRCNAM=impacket
-SRCVER=_0_9_17
-VERSION=${VERSION:-0.9.17}
+VERSION=${VERSION:-0.9.21}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,9 +63,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$SRCNAM$SRCVER
-tar -xzvf $CWD/$SRCNAM-$SRCNAM$SRCVER.tar.gz
-cd $SRCNAM-$SRCNAM$SRCVER
+rm -rf $SRCNAM-$VERSION
+tar -xzvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -74,6 +73,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/libraries/Impacket/Impacket.info b/libraries/Impacket/Impacket.info
index 41652e8617..8b1ba5529d 100644
--- a/libraries/Impacket/Impacket.info
+++ b/libraries/Impacket/Impacket.info
@@ -1,10 +1,10 @@
PRGNAM="Impacket"
-VERSION="0.9.17"
-HOMEPAGE="https://www.coresecurity.com/corelabs-research/open-source-tools/impacket"
-DOWNLOAD="https://github.com/CoreSecurity/impacket/archive/impacket_0_9_17/impacket-impacket_0_9_17.tar.gz"
-MD5SUM="a53a34898856307c79c02fcd8b8b1cb4"
+VERSION="0.9.21"
+HOMEPAGE="https://github.com/SecureAuthCorp/impacket"
+DOWNLOAD="https://pypi.io/packages/source/i/impacket/impacket-0.9.21.tar.gz"
+MD5SUM="c0a71706c09c7343905c9395076d7e31"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pyasn1 pycrypto six"
+REQUIRES="pyasn1 pycrypto six python3-six"
MAINTAINER="Brenton Earl"
EMAIL="brent@exitstatusone.com"
diff --git a/libraries/Impacket/README b/libraries/Impacket/README
index 00e4b5f792..6b9de911f9 100644
--- a/libraries/Impacket/README
+++ b/libraries/Impacket/README
@@ -3,7 +3,7 @@ to network packets. Impacket allows Python developers to craft and
decode network packets in simple and consistent manner. It includes
support for low-level protocols such as IP, UDP and TCP, as well as
higher-level protocols such as NMB and SMB. Impacket is highly effective
-when used in conjunction with a packet capture utility or package such as
-Pcapy. Packets can be constructed from scratch, as well as parsed from
-raw data. Furthermore, the object oriented API makes it simple to work
-with deep protocol hierarchies.
+when used in conjunction with a packet capture utility or package such
+as Pcapy. Packets can be constructed from scratch, as well as parsed
+from raw data. Furthermore, the object oriented API makes it simple to
+work with deep protocol hierarchies.
diff --git a/libraries/Impacket/slack-desc b/libraries/Impacket/slack-desc
index 76de7c50f6..90a47a07d9 100644
--- a/libraries/Impacket/slack-desc
+++ b/libraries/Impacket/slack-desc
@@ -14,6 +14,6 @@ Impacket: decode network packets in simple and consistent manner. It includes
Impacket: support for low-level protocols such as IP, UDP and TCP, as well as
Impacket: higher-level protocols such as NMB and SMB.
Impacket:
-Impacket: Home page: https://github.com/CoreSecurity/impacket
+Impacket: Home page: https://github.com/SecureAuthCorp/impacket
Impacket:
Impacket: