summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-08-12 15:29:38 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-13 07:22:40 +0700
commit1a290a1051949f0639b53646c23cbbac55034735 (patch)
tree63c91e10ea11a9dd7ad45c56790283200480efb8
parentb9307e3fb1ff3aba0c97c83769dcdc6daa7cd73b (diff)
downloadslackbuilds-1a290a1051949f0639b53646c23cbbac55034735.tar.gz
slackbuilds-1a290a1051949f0639b53646c23cbbac55034735.tar.xz
python/PyGithub: Updated for version 1.27.1.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/PyGithub/PyGithub.SlackBuild14
-rw-r--r--python/PyGithub/PyGithub.info8
2 files changed, 11 insertions, 11 deletions
diff --git a/python/PyGithub/PyGithub.SlackBuild b/python/PyGithub/PyGithub.SlackBuild
index 328017eda5..5e0864ee16 100644
--- a/python/PyGithub/PyGithub.SlackBuild
+++ b/python/PyGithub/PyGithub.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for PyGithub
-# Copyright 2014-2015 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=PyGithub
-VERSION=${VERSION:-1.26.0}
+VERSION=${VERSION:-1.27.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -75,7 +75,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md COPYING* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/PyGithub/PyGithub.info b/python/PyGithub/PyGithub.info
index 21ab132ebc..9ee14738e7 100644
--- a/python/PyGithub/PyGithub.info
+++ b/python/PyGithub/PyGithub.info
@@ -1,8 +1,8 @@
PRGNAM="PyGithub"
-VERSION="1.26.0"
-HOMEPAGE="http://jacquev6.github.io/PyGithub/v1/index.html"
-DOWNLOAD="https://pypi.python.org/packages/source/P/PyGithub/PyGithub-1.26.0.tar.gz"
-MD5SUM="5a9961b4331d63cbbcae3850abcf888a"
+VERSION="1.27.1"
+HOMEPAGE="http://pygithub.github.io/PyGithub/v1/index.html"
+DOWNLOAD="https://pypi.python.org/packages/72/73/e240d16b15c6170b95bc3949c9b460e0ca70e9520349c765c3a356d4ca10/PyGithub-1.27.1.tar.gz"
+MD5SUM="71b34f4bfa2d7089681e7bf7db8031f1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""