summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2016-08-14 23:36:01 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-20 07:51:32 +0700
commit2366720739588198761c04e410706110100322b1 (patch)
treecbe5de60fdb978602f2722799153a87888af8e29
parentd75f24e6f741be9264a5dcce2176a45653722bee (diff)
downloadslackbuilds-2366720739588198761c04e410706110100322b1.tar.gz
slackbuilds-2366720739588198761c04e410706110100322b1.tar.xz
office/calibre: Updated for version 2.64.0
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
-rw-r--r--office/calibre/calibre.SlackBuild19
-rw-r--r--office/calibre/calibre.info8
-rw-r--r--office/calibre/patches/calibre-module-fix.patch6
3 files changed, 16 insertions, 17 deletions
diff --git a/office/calibre/calibre.SlackBuild b/office/calibre/calibre.SlackBuild
index 7964020b2c..daa0bd5546 100644
--- a/office/calibre/calibre.SlackBuild
+++ b/office/calibre/calibre.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for calibre
-# Copyright 2009-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=calibre
-VERSION=${VERSION:-1.48.0}
+VERSION=${VERSION:-2.64.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,15 +60,15 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
+rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
-cd $PRGNAM
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Remove desktop integration. We'll do that later.
patch -p1 < $CWD/patches/remove-desktop-integration.patch
@@ -99,12 +99,11 @@ python setup.py install \
--staging-bindir=$PKG/usr/bin \
--staging-sharedir=$PKG/usr/share
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Fix permissions.
find $PKG/usr/lib${LIBDIRSUFFIX} -iname "*\.py" -exec chmod 0644 '{}' \;
-find $PKG/usr/share/$PRGNAM -type f -exec chmod 0644 '{}' \;
# Install the necessary desktop items.
mkdir -p $PKG/usr/share/{applications,mime/packages}
diff --git a/office/calibre/calibre.info b/office/calibre/calibre.info
index cb1a25b5a4..73364ff242 100644
--- a/office/calibre/calibre.info
+++ b/office/calibre/calibre.info
@@ -1,10 +1,10 @@
PRGNAM="calibre"
-VERSION="1.48.0"
+VERSION="2.64.0"
HOMEPAGE="http://calibre-ebook.com"
-DOWNLOAD="http://downloads.sourceforge.net/calibre/calibre-1.48.0.tar.xz"
-MD5SUM="1a7c680453d30643bb7426706d0d8399"
+DOWNLOAD="https://download.calibre-ebook.com/2.64.0/calibre-2.64.0.tar.xz"
+MD5SUM="198266f13ac0ed743ce2532cc6bf9bcc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="cssutils dnspython lxml mechanize podofo python-dateutil netifaces psutil cssselect apsw"
+REQUIRES="cssutils dnspython lxml mechanize podofo python-dateutil netifaces psutil cssselect apsw optipng PyQt5 Pygments"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/office/calibre/patches/calibre-module-fix.patch b/office/calibre/patches/calibre-module-fix.patch
index d2288d288e..6c0ee5178b 100644
--- a/office/calibre/patches/calibre-module-fix.patch
+++ b/office/calibre/patches/calibre-module-fix.patch
@@ -9,6 +9,6 @@ diff -Naur calibre.orig/setup/install.py calibre/setup/install.py
+ libdir = s.get_python_lib(prefix=(self.opts.staging_root + sys.prefix))
+ if not os.path.exists(libdir):
+ os.makedirs(libdir)
- if os.path.exists(libdir):
- path = os.path.join(libdir, 'init_calibre.py')
- self.info('Installing calibre environment module: '+path)
+ try:
+ if not os.path.exists(libdir):
+ os.makedirs(libdir)