summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2022-05-20 20:05:20 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-21 08:25:28 +0700
commit2bd0b0041f0914aa3b9334d7cc3fa136010a139b (patch)
treead1b7089b17f9bd1b7d757c9a3d5d836084bf30f
parent85e37d9b028e7e5fa88ea69bd24d44767cbe0a88 (diff)
downloadslackbuilds-2bd0b0041f0914aa3b9334d7cc3fa136010a139b.tar.gz
slackbuilds-2bd0b0041f0914aa3b9334d7cc3fa136010a139b.tar.xz
python/Flask-RESTful: Removed. Python3 script added.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/Flask-RESTful/Flask-RESTful.SlackBuild95
-rw-r--r--python/Flask-RESTful/Flask-RESTful.info10
-rw-r--r--python/Flask-RESTful/README2
-rw-r--r--python/Flask-RESTful/slack-desc19
4 files changed, 0 insertions, 126 deletions
diff --git a/python/Flask-RESTful/Flask-RESTful.SlackBuild b/python/Flask-RESTful/Flask-RESTful.SlackBuild
deleted file mode 100644
index aa4aec8ae7..0000000000
--- a/python/Flask-RESTful/Flask-RESTful.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Flask-RESTful
-
-# Copyright 2016-2017 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Flask-RESTful
-VERSION=${VERSION:-0.3.6}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS.md LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/Flask-RESTful/Flask-RESTful.info b/python/Flask-RESTful/Flask-RESTful.info
deleted file mode 100644
index 721f5cb507..0000000000
--- a/python/Flask-RESTful/Flask-RESTful.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Flask-RESTful"
-VERSION="0.3.6"
-HOMEPAGE="https://github.com/flask-restful/flask-restful/"
-DOWNLOAD="https://pypi.python.org/packages/20/f1/14a62bba209ae189e5c5fa33d5e0b7a4b5969488fa71fd3b8b323860bfc8/Flask-RESTful-0.3.6.tar.gz"
-MD5SUM="8243ca101185b130d8fa529cbdbdbddd"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="aniso8601 Flask pytz"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/Flask-RESTful/README b/python/Flask-RESTful/README
deleted file mode 100644
index 627d7399a1..0000000000
--- a/python/Flask-RESTful/README
+++ /dev/null
@@ -1,2 +0,0 @@
-Flask-RESTful provides the building blocks for creating a great
-REST API.
diff --git a/python/Flask-RESTful/slack-desc b/python/Flask-RESTful/slack-desc
deleted file mode 100644
index 053478ebc5..0000000000
--- a/python/Flask-RESTful/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Flask-RESTful: Flask-RESTful (framework for creating REST APIs)
-Flask-RESTful:
-Flask-RESTful: Flask-RESTful provides the building blocks for creating a great
-Flask-RESTful: REST API.
-Flask-RESTful:
-Flask-RESTful: Homepage: https://github.com/flask-restful/flask-restful/
-Flask-RESTful:
-Flask-RESTful:
-Flask-RESTful:
-Flask-RESTful:
-Flask-RESTful: