summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2017-05-07 18:11:21 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-05-13 06:58:58 +0700
commit57dd8296a01757998dd078b836ab47100e9e3498 (patch)
tree8d703a1a207492243704dc18f589acde1cfb6a56
parent70eb9114116f39524af3f9fd3511cfe7a311bfd4 (diff)
downloadslackbuilds-57dd8296a01757998dd078b836ab47100e9e3498.tar.gz
slackbuilds-57dd8296a01757998dd078b836ab47100e9e3498.tar.xz
python/python-m2r: Added (Markdown to reStructuredText converter).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-m2r/README5
-rw-r--r--python/python-m2r/python-m2r.SlackBuild92
-rw-r--r--python/python-m2r/python-m2r.info10
-rw-r--r--python/python-m2r/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/python/python-m2r/README b/python/python-m2r/README
new file mode 100644
index 0000000000..61a2647c9b
--- /dev/null
+++ b/python/python-m2r/README
@@ -0,0 +1,5 @@
+python-m2r (Markdown to reStructuredText converter)
+
+python-m2r converts a markdown file with reST markups to valid reST.
+
+Optional dependency: python3
diff --git a/python/python-m2r/python-m2r.SlackBuild b/python/python-m2r/python-m2r.SlackBuild
new file mode 100644
index 0000000000..5266caf7f1
--- /dev/null
+++ b/python/python-m2r/python-m2r.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for python-m2r
+
+# Copyright 2017 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-m2r
+VERSION=${VERSION:-0.1.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ rm -rf build
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-m2r/python-m2r.info b/python/python-m2r/python-m2r.info
new file mode 100644
index 0000000000..5b2021b468
--- /dev/null
+++ b/python/python-m2r/python-m2r.info
@@ -0,0 +1,10 @@
+PRGNAM="python-m2r"
+VERSION="0.1.5"
+HOMEPAGE="https://pypi.python.org/pypi/m2r"
+DOWNLOAD="https://pypi.python.org/packages/9b/10/ed0ca851c44034167eabbecf2c23e33e57fe0c270e83339259ec52d682e7/m2r-0.1.5.tar.gz"
+MD5SUM="9873ec4bab2c27580f3ffeb25d98a3db"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="docutils mistune"
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"
diff --git a/python/python-m2r/slack-desc b/python/python-m2r/slack-desc
new file mode 100644
index 0000000000..2df057a6b6
--- /dev/null
+++ b/python/python-m2r/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-m2r: python-m2r (Markdown to reStructuredText converter)
+python-m2r:
+python-m2r: python-m2r converts a markdown file with reST markups to valid reST.
+python-m2r:
+python-m2r: https://pypi.python.org/pypi/m2r
+python-m2r:
+python-m2r:
+python-m2r:
+python-m2r:
+python-m2r:
+python-m2r: