summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Steven Pledger <piratesmack@ymail.com>2010-03-21 02:03:55 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-05-13 14:10:29 +0200
commit97cf0484cd15280206e91ab2795d1714db0fb988 (patch)
tree183170ac82d54a1bebf751026192b62e2048ebc2
parent79a1d2944524f22d13d0da2d3161e380cf10f14d (diff)
downloadslackbuilds-97cf0484cd15280206e91ab2795d1714db0fb988.tar.gz
slackbuilds-97cf0484cd15280206e91ab2795d1714db0fb988.tar.xz
libraries/python-twitter: Added.
This provides a pure python interface for the Twitter API.
-rw-r--r--libraries/python-twitter/README8
-rwxr-xr-xlibraries/python-twitter/python-twitter.SlackBuild47
-rw-r--r--libraries/python-twitter/python-twitter.info10
-rw-r--r--libraries/python-twitter/slack-desc19
4 files changed, 84 insertions, 0 deletions
diff --git a/libraries/python-twitter/README b/libraries/python-twitter/README
new file mode 100644
index 0000000000..5d2d398bb1
--- /dev/null
+++ b/libraries/python-twitter/README
@@ -0,0 +1,8 @@
+This library provides a pure python interface for the Twitter API.
+
+Twitter (http://twitter.com) provides a service that allows people
+to connect via the web, IM, and SMS. Twitter exposes a web services
+API (http://twitter.com/help/api) and this library is intended to
+make it even easier for python programmers to use.
+
+This requires simplejson.
diff --git a/libraries/python-twitter/python-twitter.SlackBuild b/libraries/python-twitter/python-twitter.SlackBuild
new file mode 100755
index 0000000000..fd7e13812b
--- /dev/null
+++ b/libraries/python-twitter/python-twitter.SlackBuild
@@ -0,0 +1,47 @@
+#!/bin/sh
+
+# Slackware build script for python-twitter
+# Written by Steven Pledger <piratesmack@ymail.com>
+
+PRGNAM=python-twitter
+VERSION=${VERSION:-0.6}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES COPYING LICENSE NOTICE README doc/* examples \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-twitter/python-twitter.info b/libraries/python-twitter/python-twitter.info
new file mode 100644
index 0000000000..9a8f5ff289
--- /dev/null
+++ b/libraries/python-twitter/python-twitter.info
@@ -0,0 +1,10 @@
+PRGNAM="python-twitter"
+VERSION="0.6"
+HOMEPAGE="http://code.google.com/p/python-twitter/"
+DOWNLOAD="http://python-twitter.googlecode.com/files/python-twitter-0.6.tar.gz"
+MD5SUM="e1f5c50c60c74944d29ce28178972b95"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Steven Pledger"
+EMAIL="piratesmack@ymail.com"
+APPROVED="rworkman"
diff --git a/libraries/python-twitter/slack-desc b/libraries/python-twitter/slack-desc
new file mode 100644
index 0000000000..b277876756
--- /dev/null
+++ b/libraries/python-twitter/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-twitter: python-twitter (python wrapper around the Twitter API)
+python-twitter:
+python-twitter: This library provides a pure python interface for the Twitter API.
+python-twitter:
+python-twitter: Homepage: http://code.google.com/p/python-twitter/
+python-twitter:
+python-twitter:
+python-twitter:
+python-twitter:
+python-twitter:
+python-twitter: