summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Frank Caraballo <fecaraballo{at}gmail{dot}com>2010-05-13 00:26:36 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:26:36 +0200
commit9c0f355775a9f276316f78b697a962a24dd10386 (patch)
tree6813a2ce6b13bc229f491153bc6524b103fe4cd6
parent6361b88e84d5061c2b7908a6437a4eba779ac328 (diff)
downloadslackbuilds-9c0f355775a9f276316f78b697a962a24dd10386.tar.gz
slackbuilds-9c0f355775a9f276316f78b697a962a24dd10386.tar.xz
games/loemu: Updated for version 0.3.1
-rw-r--r--games/loemu/loemu.SlackBuild11
-rw-r--r--games/loemu/loemu.info2
2 files changed, 10 insertions, 3 deletions
diff --git a/games/loemu/loemu.SlackBuild b/games/loemu/loemu.SlackBuild
index 09f5304da5..21998e8af8 100644
--- a/games/loemu/loemu.SlackBuild
+++ b/games/loemu/loemu.SlackBuild
@@ -35,10 +35,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
rm -rf $PKG
@@ -60,8 +63,10 @@ python setup.py build || exit 1
python setup.py install --root $PKG || exit 1
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
@@ -80,4 +85,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/loemu/loemu.info b/games/loemu/loemu.info
index 5b63f99361..6e0eaf029f 100644
--- a/games/loemu/loemu.info
+++ b/games/loemu/loemu.info
@@ -2,7 +2,9 @@ PRGNAM="loemu"
VERSION="0.3.1"
HOMEPAGE="http://loemu.pegueroles.com"
DOWNLOAD="http://loemu.pegueroles.com/dists/loemu-0.3.1.tar.gz"
+DOWNLOAD_x86_64=""
MD5SUM="c2ac4dc230511d48761c0781f50aa1a1"
+MD5SUM_x86_64=""
MAINTAINER="Frank Caraballo"
EMAIL="fecaraballo{at}gmail{dot}com"
APPROVED="dsomero"