summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2022-05-20 22:31:43 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-21 08:25:31 +0700
commita05426545f63dfd23f451bbdfc60ece278ee0a8d (patch)
tree2cf94a99c16a38d03877910cfb5c8f003215abad
parent30738594e1b0bee03553d2cc3bb69ea649dbd136 (diff)
downloadslackbuilds-a05426545f63dfd23f451bbdfc60ece278ee0a8d.tar.gz
slackbuilds-a05426545f63dfd23f451bbdfc60ece278ee0a8d.tar.xz
python/python3-Flask-RESTX: Added (community fork of Flask-RESTPlus)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-Flask-RESTX/README7
-rw-r--r--python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild96
-rw-r--r--python/python3-Flask-RESTX/python3-Flask-RESTX.info10
-rw-r--r--python/python3-Flask-RESTX/slack-desc19
4 files changed, 132 insertions, 0 deletions
diff --git a/python/python3-Flask-RESTX/README b/python/python3-Flask-RESTX/README
new file mode 100644
index 0000000000..8ba776d18a
--- /dev/null
+++ b/python/python3-Flask-RESTX/README
@@ -0,0 +1,7 @@
+python3-Flask-RESTX (community driven fork of Flask-RESTPlus)
+
+Flask-RESTX is an extension for Flask that adds support for quickly
+building REST APIs. Flask-RESTX encourages best practices with minimal
+setup. If you are familiar with Flask, Flask-RESTX should be easy to
+pick up. It provides a coherent collection of decorators and tools to
+describe your API and expose its documentation properly using Swagger.
diff --git a/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild b/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild
new file mode 100644
index 0000000000..acdc4fc203
--- /dev/null
+++ b/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+
+# Slackware build script for python3-Flask-RESTX
+
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-Flask-RESTX
+SRCNAM=$(echo ${PRGNAM,,} | sed "s/python3-//")
+VERSION=${VERSION:-0.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-Flask-RESTX/python3-Flask-RESTX.info b/python/python3-Flask-RESTX/python3-Flask-RESTX.info
new file mode 100644
index 0000000000..f8e197e931
--- /dev/null
+++ b/python/python3-Flask-RESTX/python3-Flask-RESTX.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-Flask-RESTX"
+VERSION="0.5.1"
+HOMEPAGE="https://github.com/python-restx/flask-restx"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-restx/flask-restx-0.5.1.tar.gz"
+MD5SUM="2bedf3cdc18c689f200d2da0888b5e88"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-aniso8601 Flask python3-jsonschema pytz"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-Flask-RESTX/slack-desc b/python/python3-Flask-RESTX/slack-desc
new file mode 100644
index 0000000000..f245bf68d5
--- /dev/null
+++ b/python/python3-Flask-RESTX/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-Flask-RESTX: python3-Flask-RESTX (community driven fork of Flask-RESTPlus)
+python3-Flask-RESTX:
+python3-Flask-RESTX: Flask-RESTX is an extension for Flask that adds support for quickly
+python3-Flask-RESTX: building REST APIs. Flask-RESTX encourages best practices with minimal
+python3-Flask-RESTX: setup. If you are familiar with Flask, Flask-RESTX should be easy to
+python3-Flask-RESTX: pick up. It provides a coherent collection of decorators and tools to
+python3-Flask-RESTX: describe your API and expose its documentation properly using Swagger.
+python3-Flask-RESTX:
+python3-Flask-RESTX: Homepage: https://github.com/python-restx/flask-restx
+python3-Flask-RESTX:
+python3-Flask-RESTX: