summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-01-18 16:21:01 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-01-28 08:23:13 +0700
commitadfe6bf784480f736b4f3984ab4ca30303f96e84 (patch)
tree95018042978442e7b8fd7b41ffc3cd949128b48d
parent887f96460bff6bbff8fd2127103411ea18e27e70 (diff)
downloadslackbuilds-adfe6bf784480f736b4f3984ab4ca30303f96e84.tar.gz
slackbuilds-adfe6bf784480f736b4f3984ab4ca30303f96e84.tar.xz
development/inform: Updated for version 6.41_r2.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/inform/destdir.diff28
-rw-r--r--development/inform/inform.SlackBuild21
-rw-r--r--development/inform/inform.info12
3 files changed, 39 insertions, 22 deletions
diff --git a/development/inform/destdir.diff b/development/inform/destdir.diff
index c85bbf9563..3713cf2fd3 100644
--- a/development/inform/destdir.diff
+++ b/development/inform/destdir.diff
@@ -1,16 +1,16 @@
-diff -Naur inform-6.35-r2/Makefile inform-6.35-r2.patched/Makefile
---- inform-6.35-r2/Makefile 2021-06-22 00:31:25.000000000 -0400
-+++ inform-6.35-r2.patched/Makefile 2021-09-01 15:38:28.641094355 -0400
-@@ -155,7 +155,7 @@
- strip $(BINNAME)
+diff -Naur inform-6.41-r2/Makefile inform-6.41-r2.patched/Makefile
+--- inform-6.41-r2/Makefile 2022-11-21 19:31:13.000000000 -0500
++++ inform-6.41-r2.patched/Makefile 2023-01-18 15:22:43.134613101 -0500
+@@ -178,7 +178,7 @@
install-compiler: $(BINNAME)
+ ifeq ($(wildcard $(DESTDIR)$(BINDIR)/$(BINNAME)),)
- install -d -m $(DIRPERM) $(DESTDIR)$(BINDIR)
+ mkdir -p -m $(DIRPERM) $(DESTDIR)$(BINDIR)
install -c -m $(BINPERM) $(BINNAME) $(DESTDIR)$(BINDIR)
-
- #########################################################
-@@ -172,24 +172,23 @@
+ cd $(DESTDIR)$(BINDIR) ; ln -sf $(BINNAME) $(NAME)
+ @echo "** Done installing compiler."
+@@ -218,24 +218,24 @@
install-stdlib-all: install-stdlib install-stdinc install-stddemos install-stdtutor
install-stdlib:
@@ -19,6 +19,7 @@ diff -Naur inform-6.35-r2/Makefile inform-6.35-r2.patched/Makefile
- @./fixlinks.sh $(STDLIB) $(STDLIB_LINKS)
+ mkdir -p -m $(DIRPERM) $(DESTDIR)$(STDLIB)
+ install -c -m $(FILEPERM) $(wildcard ${STDSRC}/*) $(DESTDIR)$(STDLIB)
++ @./fixlinks.sh $(DESTDIR)$(STDLIB) $(STDLIB_LINKS)
@echo "** Done installing Standard Library."
install-stdinc:
@@ -43,13 +44,14 @@ diff -Naur inform-6.35-r2/Makefile inform-6.35-r2.patched/Makefile
@echo "** Done installing Standard Library tutorials."
-@@ -206,38 +205,40 @@
+@@ -252,39 +252,41 @@
install-punywrapper:
- sed 's,^LIBPATH.*,LIBPATH=${SHAREDIR},g' $(PUNYINFORMSH) > $(PUNYINFORMSH)-scratch
+ sed 's,^LIBPATH.*,LIBPATH=$(REAL_PREFIX)/share/$(NAME),g' $(PUNYINFORMSH) > $(PUNYINFORMSH)-scratch
+ mkdir -p -m $(DIRPERM) $(DESTDIR)$(BINDIR)
install -c -m $(BINPERM) $(PUNYINFORMSH)-scratch $(DESTDIR)$(BINDIR)/$(PUNYINFORMSH)
cd $(DESTDIR)$(BINDIR) ; ln -sf $(PUNYINFORMSH) $(PUNYINFORM)
+ cd $(DESTDIR)$(BINDIR) ; ln -sf $(PUNYINFORMSH) $(PUNYINFORM)-$(COMPVERSION)
rm -f $(PUNYINFORMSH)-scratch
install-punylib:
@@ -100,9 +102,9 @@ diff -Naur inform-6.35-r2/Makefile inform-6.35-r2.patched/Makefile
install-puny: install-punylib install-punywrapper install-punymisc install-punyhowto install-punytests install-punydocs
-@@ -246,16 +247,17 @@
+@@ -292,16 +294,17 @@
+ #############################
# Installing everything else
-
install-manual:
- install -d -m $(DIRPERM) $(MANDIR)
- install -c -m $(FILEPERM) $(MANPAGE) $(MANDIR)
@@ -120,4 +122,4 @@ diff -Naur inform-6.35-r2/Makefile inform-6.35-r2.patched/Makefile
+install-strip: all strip install
uninstall:
- rm -f $(DESTDIR)$(BINDIR)/$(BINNAME)
+ rm -f $(DESTDIR)$(BINDIR)/$(NAME)*
diff --git a/development/inform/inform.SlackBuild b/development/inform/inform.SlackBuild
index d1caf63e71..0e5e1a7083 100644
--- a/development/inform/inform.SlackBuild
+++ b/development/inform/inform.SlackBuild
@@ -6,6 +6,11 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230118 bkw: updated for v6.41_r2.
+# - add the Inform 6 Addendum to the package.
+# - destdir.diff had to change, can't build previous version any more.
+# - symlink library demos and tutorial to doc dir.
+
# 20210831 bkw:
# - updated for v6.35_r2 (upstream changed their version numbering
# scheme again). script had to change a lot, so can't build old
@@ -29,7 +34,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=inform
-VERSION=${VERSION:-6.35_r2}
+VERSION=${VERSION:-6.41_r2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -124,7 +129,7 @@ ln -s ../games/$PRGNAM $PKG/usr/bin/$PRGNAM
name=${file%%.*}
# Name.h NAME.h
for link in ${name^}.h ${name^^}.h; do
- ln -s $file $link
+ ln -sf $file $link
done
done
@@ -136,7 +141,7 @@ ln -s ../games/$PRGNAM $PKG/usr/bin/$PRGNAM
InfGlk InfGLK infGlk infGLK \
LinkLpa LinkLPA linkLpa linkLPA
do
- ln -s ${link,,}.h $link.h
+ ln -sf ${link,,}.h $link.h
done
# Any of the above might appear with .H. Use readlink so all the
@@ -146,7 +151,7 @@ ln -s ../games/$PRGNAM $PKG/usr/bin/$PRGNAM
for file in *.h; do
dest="${file%%.*}.H"
[ -L "$file" ] && file="$( readlink $file )"
- ln -s $file $dest
+ ln -sf $file $dest
done
)
@@ -164,12 +169,20 @@ mkdir -p $PKGDOC/manual
cat $CWD/IBG.pdf > $PKGDOC/inform_beginners_guide.pdf
ln -s inform_beginners_guide.pdf $PKGDOC/IBG.pdf
+# Also the addendum to the manual, because the manual's a bit dated.
+cat $CWD/I6-Addendum.html > $PKGDOC/inform_6_addendum.html
+ln -s inform_6_addendum.html $PKGDOC/I6-Addendum.html
+
# Library documentation should be visibile in /usr/doc.
mkdir -p $PKGDOC/lib
for i in ChangeLog README.txt voices_and_tenses.txt; do
ln -s ../../../share/$PRGNAM/std/lib/$i $PKGDOC/lib
done
+# 20230118 bkw: Demos and tutorial will be easier to find if they're
+# visible from the doc dir.
+ln -s ../../share/inform/std/{demos,tutor} $PKGDOC
+
# Same for punyinform docs.
mkdir -p $PKGDOC/punyinform
for i in README.md LICENSE documentation; do
diff --git a/development/inform/inform.info b/development/inform/inform.info
index 8cff832abc..9cccec8441 100644
--- a/development/inform/inform.info
+++ b/development/inform/inform.info
@@ -1,12 +1,14 @@
PRGNAM="inform"
-VERSION="6.35_r2"
+VERSION="6.41_r2"
HOMEPAGE="http://www.inform-fiction.org/"
-DOWNLOAD="https://slackware.uk/~urchlay/src/inform-6.35-r2.tar.gz \
+DOWNLOAD="https://slackware.uk/~urchlay/src/inform-6.41-r2.tar.gz \
http://www.ifarchive.org/if-archive/infocom/compilers/inform6/manuals/designers_manual_4.zip \
- http://www.ifarchive.org/if-archive/infocom/compilers/inform6/manuals/IBG.pdf"
-MD5SUM="9035fb1469ae9a39c077b5b55f05aebc \
+ http://www.ifarchive.org/if-archive/infocom/compilers/inform6/manuals/IBG.pdf \
+ http://www.inform-fiction.org/manual/I6-Addendum.html"
+MD5SUM="a38fc48ddf90fe8ac8c7a5c03322fe6e \
0063968c3378636add1a0697b6d1fc16 \
- b2635d3d61313bed286409500fc55bed"
+ b2635d3d61313bed286409500fc55bed \
+ 5051762b361155ce61ed84924825a7c0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""