summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2016-12-16 23:41:55 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-17 01:18:31 +0700
commitb4998a9d87cec831f236601ba71a4633c5b9edaf (patch)
treeaa346c7ba04671e2a4180f23a5bb52b99963eae5
parent70531054c49799ca9eb1820470c73f122652cdd1 (diff)
downloadslackbuilds-b4998a9d87cec831f236601ba71a4633c5b9edaf.tar.gz
slackbuilds-b4998a9d87cec831f236601ba71a4633c5b9edaf.tar.xz
libraries/sqlpp11: Added (A type safe SQL template library for C++).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/sqlpp11/README9
-rw-r--r--libraries/sqlpp11/slack-desc19
-rw-r--r--libraries/sqlpp11/sqlpp11.SlackBuild96
-rw-r--r--libraries/sqlpp11/sqlpp11.info10
-rw-r--r--libraries/sqlpp11/sqlpp11.patch13
5 files changed, 147 insertions, 0 deletions
diff --git a/libraries/sqlpp11/README b/libraries/sqlpp11/README
new file mode 100644
index 0000000000..54db5a368b
--- /dev/null
+++ b/libraries/sqlpp11/README
@@ -0,0 +1,9 @@
+sqlpp11 offers you to code SQL in C++ almost naturally. You can use
+tables, columns and functions. Everything has strong types which
+allow the compiler to help you a lot. At compile time, it will tell
+about most of those pesky oversight errors you can make (typos,
+comparing apples with oranges, forgetting tables in a select
+statement, etc). And it does not stop at query construction.
+Results have ranges, and strongly typed members, so that you can
+browse through results in a type-safe manner, worthy of modern
+C++.
diff --git a/libraries/sqlpp11/slack-desc b/libraries/sqlpp11/slack-desc
new file mode 100644
index 0000000000..2113fb160b
--- /dev/null
+++ b/libraries/sqlpp11/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+sqlpp11: sqlpp11 (A type safe SQL template library for C++)
+sqlpp11:
+sqlpp11: sqlpp11 offers you to code SQL in C++ almost naturally. You
+sqlpp11: can use tables, columns and functions. Everything has strong
+sqlpp11: types which allow the compiler to help you a lot. At compile
+sqlpp11: time, it will tell about most of those pesky oversight
+sqlpp11: errors you can make
+sqlpp11:
+sqlpp11:
+sqlpp11: https://github.com/rbock/sqlpp11
+sqlpp11:
diff --git a/libraries/sqlpp11/sqlpp11.SlackBuild b/libraries/sqlpp11/sqlpp11.SlackBuild
new file mode 100644
index 0000000000..d9e87ba1e8
--- /dev/null
+++ b/libraries/sqlpp11/sqlpp11.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/sh
+
+# Slackware build script for sqlpp11
+
+# Copyright 2016 Andre Barboza, Belo Horizonte - Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=sqlpp11
+VERSION=${VERSION:-0.43}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+patch -p1 < $CWD/sqlpp11.patch
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+# -DHinnantDate_ROOT_DIR="/usr/include" ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+mkdir -p $PKG/usr/bin
+install -m 755 scripts/ddl2cpp $PKG/usr/bin
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -ar ChangeLog.md README.md examples/ CREDITS LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/sqlpp11/sqlpp11.info b/libraries/sqlpp11/sqlpp11.info
new file mode 100644
index 0000000000..617e7dd29c
--- /dev/null
+++ b/libraries/sqlpp11/sqlpp11.info
@@ -0,0 +1,10 @@
+PRGNAM="sqlpp11"
+VERSION="0.43"
+HOMEPAGE="https://github.com/rbock/sqlpp11"
+DOWNLOAD="https://github.com/rbock/sqlpp11/archive/0.43/sqlpp11-0.43.tar.gz"
+MD5SUM="e7f1a009156e3459740b26bb5dd1db1a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyparsing hinnant-date"
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
diff --git a/libraries/sqlpp11/sqlpp11.patch b/libraries/sqlpp11/sqlpp11.patch
new file mode 100644
index 0000000000..c405b86587
--- /dev/null
+++ b/libraries/sqlpp11/sqlpp11.patch
@@ -0,0 +1,13 @@
+Only in sqlpp11-0.43: .CMakeLists.txt.un~
+diff -ur sqlpp11-0.43.old/CMakeLists.txt sqlpp11-0.43/CMakeLists.txt
+--- sqlpp11-0.43.old/CMakeLists.txt 2016-09-13 17:04:51.000000000 -0300
++++ sqlpp11-0.43/CMakeLists.txt 2016-12-13 18:21:29.848155499 -0200
+@@ -87,7 +87,7 @@
+ COPYONLY
+ )
+
+-set(ConfigPackageLocation lib/cmake/Sqlpp11)
++set(ConfigPackageLocation "lib${LIB_SUFFIX}/cmake/Sqlpp11")
+ install(EXPORT Sqlpp11Targets
+ FILE
+ Sqlpp11Targets.cmake