summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-08-10 19:09:32 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-13 07:22:19 +0700
commitcf83be6d3cb72f3499925a4dadc4e2e0d3437e93 (patch)
tree4703fdd3acce40692149076925b265b14fe78bc4
parent352c017698a055a14e76d2a7bba0b8c6e0a0400c (diff)
downloadslackbuilds-cf83be6d3cb72f3499925a4dadc4e2e0d3437e93.tar.gz
slackbuilds-cf83be6d3cb72f3499925a4dadc4e2e0d3437e93.tar.xz
python/Flask-Login: Added (User session management for Flask).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--python/Flask-Login/Flask-Login.SlackBuild85
-rw-r--r--python/Flask-Login/Flask-Login.info10
-rw-r--r--python/Flask-Login/README4
-rw-r--r--python/Flask-Login/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/Flask-Login/Flask-Login.SlackBuild b/python/Flask-Login/Flask-Login.SlackBuild
new file mode 100644
index 0000000000..1884b1f6ff
--- /dev/null
+++ b/python/Flask-Login/Flask-Login.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for Flask-Login
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=Flask-Login
+VERSION=${VERSION:-0.3.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/Flask-Login/Flask-Login.info b/python/Flask-Login/Flask-Login.info
new file mode 100644
index 0000000000..a0515453c3
--- /dev/null
+++ b/python/Flask-Login/Flask-Login.info
@@ -0,0 +1,10 @@
+PRGNAM="Flask-Login"
+VERSION="0.3.2"
+HOMEPAGE="https://github.com/maxcountryman/flask-login"
+DOWNLOAD="https://pypi.python.org/packages/06/e6/61ed90ed8ce6752b745ed13fac3ba407dc9db95dfa2906edc8dd55dde454/Flask-Login-0.3.2.tar.gz"
+MD5SUM="d95c2275d3e1c755145910077366dc45"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="Flask"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/Flask-Login/README b/python/Flask-Login/README
new file mode 100644
index 0000000000..7ea25670c3
--- /dev/null
+++ b/python/Flask-Login/README
@@ -0,0 +1,4 @@
+Flask-Login provides user session management for Flask.
+It handles the common tasks of logging in, logging out,
+and remembering your users’ sessions over extended periods
+of time.
diff --git a/python/Flask-Login/slack-desc b/python/Flask-Login/slack-desc
new file mode 100644
index 0000000000..c322ff410c
--- /dev/null
+++ b/python/Flask-Login/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+Flask-Login: Flask-Login (User session management for Flask)
+Flask-Login:
+Flask-Login: Flask-Login provides user session management for Flask. It handles
+Flask-Login: the common tasks of logging in, logging out, and remembering your
+Flask-Login: users’ sessions over extended periods of time.
+Flask-Login:
+Flask-Login: Homepage: https://github.com/maxcountryman/flask-login
+Flask-Login:
+Flask-Login:
+Flask-Login:
+Flask-Login: