summaryrefslogtreecommitdiffstats
path: root/academic/xfoil/xfoil.SlackBuild
diff options
context:
space:
mode:
author Daniel Prosser <dpross1100@msn.com>2016-12-29 13:03:34 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-31 08:22:15 +0700
commit2d8dca281f67481bac79e58d2a8b394f8559fafd (patch)
tree38c424e4479232012174b0f985def9c52a88ca5a /academic/xfoil/xfoil.SlackBuild
parent30be0fc06647205979987ab5e1f0dc310d40a359 (diff)
downloadslackbuilds-2d8dca281f67481bac79e58d2a8b394f8559fafd.tar.gz
slackbuilds-2d8dca281f67481bac79e58d2a8b394f8559fafd.tar.xz
academic/xfoil: Added (program for design and analysis of airfoils).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/xfoil/xfoil.SlackBuild')
-rw-r--r--academic/xfoil/xfoil.SlackBuild109
1 files changed, 109 insertions, 0 deletions
diff --git a/academic/xfoil/xfoil.SlackBuild b/academic/xfoil/xfoil.SlackBuild
new file mode 100644
index 0000000000..16775a3064
--- /dev/null
+++ b/academic/xfoil/xfoil.SlackBuild
@@ -0,0 +1,109 @@
+#!/bin/sh
+
+# Slackware build script for xfoil
+
+# Copyright 2016 Daniel Prosser, Lexington Park, MD
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=xfoil
+VERSION=${VERSION:-6.99}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf Xfoil
+tar xvf $CWD/$PRGNAM$VERSION.tgz
+cd Xfoil
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i '101s/\/home\/codes\/orrs\/osmapDP.dat/\/tmp\/SBo\/Xfoil\/orrs\/osmapDP.dat/' orrs/src/osmap.f # Correct path to osmapDP.dat
+sed -i '660 a \ BACKSPACE(LU)' src/iopol.f # Avoid write errors with new gfortran
+patch -p0 < $CWD/xoper.f.patch # Get rid of hard-coded debugging output
+
+# Patches to create correct Makefiles
+patch -p0 < $CWD/Makefile_patches/Makefile.orrs.patch
+patch -p0 < $CWD/Makefile_patches/config.make.plotlib.patch
+patch -p0 < $CWD/Makefile_patches/Makefile.xfoil.patch
+
+cd orrs
+ cd bin
+ make osgen
+ make osmap.o
+ cd ..
+cd ..
+cd plotlib
+ make libPlt_gDP.a
+cd -
+cd bin
+ make xfoil
+ make pplot
+ make pxplot
+ make install DESTDIR="$PKG"
+cd -
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README xfoil_doc.txt sessions.txt version_notes.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}