summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Fellype do Nascimento <fellype(at)gmail.com>2016-08-22 19:47:47 +0100
committer David Spencer <idlemoor@slackbuilds.org>2016-08-28 00:22:59 +0100
commit9864c8761df5476a34260a79a5cbfc36a9c15278 (patch)
treed98aa860249d108f4327cc2b77371bfba8ebf12c /academic
parentaf3592becd3e510aadd6ada54fae4c96c1b04c5f (diff)
downloadslackbuilds-9864c8761df5476a34260a79a5cbfc36a9c15278.tar.gz
slackbuilds-9864c8761df5476a34260a79a5cbfc36a9c15278.tar.xz
academic/veusz: Updated for version 1.24.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/veusz/README25
-rw-r--r--academic/veusz/doinst.sh10
-rw-r--r--academic/veusz/slack-desc2
-rw-r--r--academic/veusz/veusz.SlackBuild32
-rw-r--r--academic/veusz/veusz.info6
5 files changed, 44 insertions, 31 deletions
diff --git a/academic/veusz/README b/academic/veusz/README
index ed10e839e7..3656879576 100644
--- a/academic/veusz/README
+++ b/academic/veusz/README
@@ -1,15 +1,18 @@
Veusz - A Scientific Plotting Package
-Veusz is a GUI scientific plotting and graphing package.
-It is designed to produce publication-ready Postscript or PDF output.
-SVG, EMF and bitmap export formats are also supported.
+Veusz is a GUI scientific plotting and graphing package. It is designed
+to produce publication-ready Postscript or PDF output. SVG, EMF and
+bitmap export formats are also supported.
-The program runs under Unix/Linux, Windows or Mac OS X, and binaries are provided.
-Data can be read from text, CSV, HDF5 or FITS files.
-In addition, you can also enter, manipulate or examine data from within the application.
-In Veusz plots are created by building up plotting widgets with a consistent object-based interface.
-The program also provides a command line and scripting interface (based on Python) to its plotting facilities
- It can also act as a Python plotting module.
-Veusz is written in Python. Its user interface uses PyQt and Numpy is used to manipulate data.
+The program runs under Unix/Linux, Windows or Mac OS X, and binaries
+are provided. Data can be read from text, CSV, HDF5 or FITS files. In
+addition, you can also enter, manipulate or examine data from within
+the application. In Veusz plots are created by building up plotting
+widgets with a consistent object-based interface. The program also
+provides a command line and scripting interface (based on Python) to
+its plotting facilities. It can also act as a Python plotting module.
+Veusz is written in Python. Its user interface uses PyQt and Numpy is
+used to manipulate data.
-The hdf5 library is needed only if you want to use HDF5 files.
+The hdf5 library is an optional dependency (needed only if you want to
+use HDF5 files).
diff --git a/academic/veusz/doinst.sh b/academic/veusz/doinst.sh
new file mode 100644
index 0000000000..1f8ff67ded
--- /dev/null
+++ b/academic/veusz/doinst.sh
@@ -0,0 +1,10 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
diff --git a/academic/veusz/slack-desc b/academic/veusz/slack-desc
index c8b5c76f16..07357a9910 100644
--- a/academic/veusz/slack-desc
+++ b/academic/veusz/slack-desc
@@ -11,7 +11,7 @@ veusz:
veusz: Veusz is a scientific plotting package. It was designed to be easy to
veusz: use, easily extensible, but powerful. The program features a graphical
veusz: user interface, which works under Unix/Linux, Windows or Mac OS X. It
-veusz: can also be easily scripted (the saved file formats are similar to
+veusz: can also be easily scripted (the saved file formats are similar to
veusz: Python scripts) or used as module inside Python. Veusz reads data from
veusz: a number of different types of data file, it can be manually entered,
veusz: or constructed from other datasets.
diff --git a/academic/veusz/veusz.SlackBuild b/academic/veusz/veusz.SlackBuild
index d1bbf2cc2a..de515bf1cf 100644
--- a/academic/veusz/veusz.SlackBuild
+++ b/academic/veusz/veusz.SlackBuild
@@ -1,10 +1,10 @@
#!/bin/sh
# Slackware build script for veusz
-# Based on Slackware 14.1 SlackBuild and Andrea Sciucca SlackBuild for veusz
+# Based on Slackware 14.1 SlackBuild and Andrea Sciucca's SlackBuild for veusz
# Written by Fellype do Nascimento <fellype(at)gmail.com>
PRGNAM=veusz
-VERSION=${VERSION:-1.23}
+VERSION=${VERSION:-1.24}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -21,12 +21,18 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"; SLKLDFLAGS=""; LIBDIRSUFFIX=""; CHOST=i486
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"; SLKLDFLAGS=""; LIBDIRSUFFIX=""; CHOST=i486
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"; SLKLDFLAGS="-L/usr/lib64"; LIBDIRSUFFIX="64"
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
set -e
@@ -35,7 +41,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar -zxvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -46,11 +52,8 @@ find -L . \
python setup.py install --root $PKG
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs -r strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs -r strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "current ar archive" | cut -f 1 -d : | xargs -r strip --strip-unneeded 2> /dev/null || true
-)
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS ChangeLog COPYING INSTALL README VERSION $PKG/usr/doc/$PRGNAM-$VERSION
@@ -78,10 +81,7 @@ mv Documents/veusz.1.gz $PKG/usr/man/man1/
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-
-if [ -e /usr/bin/requiredbuilder ]; then
- requiredbuilder -v -y -s $CWD $PKG
-fi
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/veusz/veusz.info b/academic/veusz/veusz.info
index b6d72fd98d..ecac80bb6b 100644
--- a/academic/veusz/veusz.info
+++ b/academic/veusz/veusz.info
@@ -1,8 +1,8 @@
PRGNAM="veusz"
-VERSION="1.23"
+VERSION="1.24"
HOMEPAGE="http://home.gna.org/veusz/"
-DOWNLOAD="http://download.gna.org/veusz/veusz-1.23.tar.gz"
-MD5SUM="6e34aa330df35f0142f9e9456ec79041"
+DOWNLOAD="http://download.gna.org/veusz/veusz-1.24.tar.gz"
+MD5SUM="44e491b2accec1857d1e2336f52187ad"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="numpy"