summaryrefslogtreecommitdiffstats
path: root/accessibility/flite
diff options
context:
space:
mode:
author Martin Lefebvre <dadexter@sekurity.com.com>2010-05-11 22:38:32 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 22:38:32 +0200
commitbcb0340c922db6db9e835568f63f71a9941a3753 (patch)
treec51eeeaf2c2d57523dd40eb1200783c55b509131 /accessibility/flite
parenta2972457af61f31d31dc216f8c2a48a41a1312f0 (diff)
downloadslackbuilds-bcb0340c922db6db9e835568f63f71a9941a3753.tar.gz
slackbuilds-bcb0340c922db6db9e835568f63f71a9941a3753.tar.xz
accessibility/flite: Added to 12.1 repository
Diffstat (limited to 'accessibility/flite')
-rw-r--r--accessibility/flite/README6
-rw-r--r--accessibility/flite/flite.SlackBuild66
-rw-r--r--accessibility/flite/flite.info8
-rw-r--r--accessibility/flite/slack-desc19
4 files changed, 99 insertions, 0 deletions
diff --git a/accessibility/flite/README b/accessibility/flite/README
new file mode 100644
index 0000000000..39e752a952
--- /dev/null
+++ b/accessibility/flite/README
@@ -0,0 +1,6 @@
+Flite is a small, fast run-time synthesis engine, designed for
+embedded systems and servers. Flite was developed by Alan W Black and
+Kevin Lenzo at Carnegie Mellon University, in Pittsburgh. The
+city with TTS at its heart.
+
+This script builds flite with the 16bit voice enabled my default.
diff --git a/accessibility/flite/flite.SlackBuild b/accessibility/flite/flite.SlackBuild
new file mode 100644
index 0000000000..7b68317188
--- /dev/null
+++ b/accessibility/flite/flite.SlackBuild
@@ -0,0 +1,66 @@
+#!/bin/sh
+
+# Slackware build script for flite
+# Written by Martin Lefebvre (dadexter@sekurity.com)
+
+# Exit on most errors
+set -e
+
+PRGNAM=flite
+VERSION=1.3
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION-release
+tar -xzvf $CWD/$PRGNAM-$VERSION-release.tar.gz
+cd $PRGNAM-$VERSION-release
+chown -R root:root . || true
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-vox=cmu_us_kal16
+
+sed -i 's#@ $(MAKE) -C lib --no-print-directory install#$(INSTALL) -m 644 build/i386-linux-gnu/lib/*.a $(INSTALLLIBDIR)#g' Makefile
+
+make
+make install prefix=$PKG/usr
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ACKNOWLEDGEMENTS COPYING README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+rm $PKG/usr/doc/$PRGNAM-$VERSION/Makefile
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/accessibility/flite/flite.info b/accessibility/flite/flite.info
new file mode 100644
index 0000000000..56e200ba30
--- /dev/null
+++ b/accessibility/flite/flite.info
@@ -0,0 +1,8 @@
+PRGNAM="flite"
+VERSION="1.3"
+HOMEPAGE="http://fife.speech.cs.cmu.edu/flite/"
+DOWNLOAD="http://fife.speech.cs.cmu.edu/flite/packed/flite-1.3/flite-1.3-release.tar.gz"
+MD5SUM="ae0aca1cb7b4801f4372f3a75a9e52b5"
+MAINTAINER="Martin Lefebvre"
+EMAIL="dadexter@sekurity.com.com"
+APPROVED="rworkman"
diff --git a/accessibility/flite/slack-desc b/accessibility/flite/slack-desc
new file mode 100644
index 0000000000..6ce5589756
--- /dev/null
+++ b/accessibility/flite/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+flite: flite (speech synthesis engine)
+flite:
+flite: Flite is a small and fast run-time synthesis engine designed for
+flite: embedded systems and servers. Flite was developed by Alan W Black
+flite: and Kevin Lenzo at Carnegie Mellon University, in Pittsburgh.
+flite:
+flite:
+flite:
+flite:
+flite:
+flite: