summaryrefslogtreecommitdiffstats
path: root/audio/japa
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2014-01-16 07:14:56 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-01-29 23:21:03 -0600
commit2167efbdc487f03a115dbe4851fee06d73fbccf5 (patch)
tree7207008719d2c9ca2b089127391feb62d146ad76 /audio/japa
parentfe65c04dd2c8f8efb7831b61dab80dfb57744edd (diff)
downloadslackbuilds-2167efbdc487f03a115dbe4851fee06d73fbccf5.tar.gz
slackbuilds-2167efbdc487f03a115dbe4851fee06d73fbccf5.tar.xz
audio/japa: Added (audio spectrum analyser for JACK).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio/japa')
-rw-r--r--audio/japa/README17
-rw-r--r--audio/japa/doinst.sh3
-rw-r--r--audio/japa/japa.180
-rw-r--r--audio/japa/japa.SlackBuild95
-rw-r--r--audio/japa/japa.desktop8
-rw-r--r--audio/japa/japa.info10
-rw-r--r--audio/japa/japa.pngbin0 -> 1554 bytes
-rw-r--r--audio/japa/setcap.sh1
-rw-r--r--audio/japa/slack-desc19
9 files changed, 233 insertions, 0 deletions
diff --git a/audio/japa/README b/audio/japa/README
new file mode 100644
index 0000000000..a1ccb6ce68
--- /dev/null
+++ b/audio/japa/README
@@ -0,0 +1,17 @@
+japa (audio spectrum analyser for jack-audio-connection-kit)
+
+Japa (JACK and ALSA Perceptual Analyser), is a 'perceptual' or
+'psychoacoustic' audio spectrum analyser. Possible uses include spectrum
+monitoring while mixing or mastering, evaluation of ambient noise, and
+(using pink noise), equalisation of PA systems.
+
+By default, the package is built with '-march=native'. If you need a
+generic package that can be installed on any Slackware machine with the
+same ARCH as the build host, set FORCE_SLACK_CFLAGS=yes in the script's
+environment.
+
+This package uses POSIX filesystem capabilities to execute with
+elevated privileges (required for realtime audio processing). This
+may be considered a security/stability risk. Please read
+http://www.slackbuilds.org/caps/ for more information. To disable
+capabilities, pass SETCAP=no to the script.
diff --git a/audio/japa/doinst.sh b/audio/japa/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/audio/japa/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/audio/japa/japa.1 b/audio/japa/japa.1
new file mode 100644
index 0000000000..0a907f4311
--- /dev/null
+++ b/audio/japa/japa.1
@@ -0,0 +1,80 @@
+.TH JAPA 1 "January 14, 2014"
+.SH NAME
+japa \- JACK or ALSA perceptual analyser
+.SH SYNOPSIS
+.B japa
+.RI { -h | -A | -J }
+.RI [ options ]
+.br
+.SH DESCRIPTION
+.B Japa
+(JACK and ALSA Perceptual Analyser), is a 'perceptual' or 'psychoacoustic'
+audio spectrum analyser. Possible uses include spectrum monitoring while mixing
+or mastering, evaluation of ambient noise, and (using pink noise), equalisation
+of PA systems. For more information see /usr/doc/japa-@VERSION@/README.
+.SH OPTIONS
+One out of
+.B \-A
+and
+.B \-J
+must be given.
+.TP
+.B \-h
+Show summary of options.
+.TP
+.B \-J
+Use JACK.
+.TP
+.B \-s <server>
+Select JACK server. Default is 'default' or $JACK_DEFAULT_SERVER environment variable.
+Only valid with
+.B \-J
+option.
+.TP
+.B \-A
+Use ALSA. Options
+.B \-d
+,
+.B \-C
+,
+.B \-P
+,
+.B \-r
+,
+.B \-p
+, and
+.B \-n
+are only valid with this option.
+.TP
+.B \-d <device>
+Specify ALSA device. Defaults to hw:0.0. This option sets the
+playback and capture devices to the same device. For separate capture and playback,
+use
+.B \-C
+and
+.B \-P
+instead.
+.TP
+.B \-C <device>
+Specify alsa capture device.
+.TP
+.B \-P <device>
+Specify alsa playback device.
+.TP
+.B \-r <rate>
+Specify sample frequency. Defaults to 48000.
+.TP
+.B \-p <period>
+Specify period size. Defaults to 1024.
+.TP
+.B \-n <nfrags>
+Specify number of fragments. Defaults to 2.
+.SH SEE ALSO
+.BR jackd (1).
+.SH AUTHOR
+japa was written by Fons Adriaensen <fons@kokkinizita.net>.
+.PP
+This manual page was written by Helmut Grohne <helmut@subdivi.de>,
+for the Debian project (but may be used by others). It was modified
+by B. Watson <yalhcry@gmail.com) for the SlackBuilds.org project,
+and may still be used by others.
diff --git a/audio/japa/japa.SlackBuild b/audio/japa/japa.SlackBuild
new file mode 100644
index 0000000000..d75d7534b4
--- /dev/null
+++ b/audio/japa/japa.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+
+# Slackware build script for japa
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=japa
+VERSION=${VERSION:-0.8.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG/usr/{bin,man/man1} $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
+ sed -i \
+ -e '/march=native/d' \
+ -e "s,-O2,$SLKCFLAGS," \
+ source/Makefile
+fi
+
+make -C source PREFIX=/usr
+make -C source install PREFIX=$PKG/usr
+strip $PKG/usr/bin/$PRGNAM
+
+# man page borrowed from debian, edited a bit
+sed "s,@VERSION@,$VERSION,g" < $CWD/$PRGNAM.1 | gzip -c9 - > $PKG/usr/man/man1/$PRGNAM.1.gz
+
+# icon grabbed from old web site
+mkdir -p $PKG/usr/share/pixmaps
+cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+
+# desktop file written for this SlackBuild
+mkdir -p $PKG/usr/share/applications
+cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+if [ "${SETCAP:-yes}" = "yes" ]; then
+ cat $CWD/setcap.sh >> $PKG/install/doinst.sh
+ chown root:audio $PKG/usr/bin/$PRGNAM
+ chmod 0750 $PKG/usr/bin/$PRGNAM
+fi
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/japa/japa.desktop b/audio/japa/japa.desktop
new file mode 100644
index 0000000000..6b3dd44bb0
--- /dev/null
+++ b/audio/japa/japa.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=JAPA
+Comment=JACK and ALSA Perceptual Analyser
+Exec=japa -J
+Icon=japa
+Terminal=false
+Type=Application
+Categories=AudioVideo;Audio;X-Jack;
diff --git a/audio/japa/japa.info b/audio/japa/japa.info
new file mode 100644
index 0000000000..8d717bcffa
--- /dev/null
+++ b/audio/japa/japa.info
@@ -0,0 +1,10 @@
+PRGNAM="japa"
+VERSION="0.8.4"
+HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/"
+DOWNLOAD="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/japa-0.8.4.tar.bz2"
+MD5SUM="966a8774e5b232bf055922dfdcc1b730"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="jack-audio-connection-kit clxclient zita-alsa-pcmi"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/audio/japa/japa.png b/audio/japa/japa.png
new file mode 100644
index 0000000000..dded6976e2
--- /dev/null
+++ b/audio/japa/japa.png
Binary files differ
diff --git a/audio/japa/setcap.sh b/audio/japa/setcap.sh
new file mode 100644
index 0000000000..908db87e5d
--- /dev/null
+++ b/audio/japa/setcap.sh
@@ -0,0 +1 @@
+[ -x /sbin/setcap ] && /sbin/setcap cap_ipc_lock,cap_sys_nice=ep usr/bin/japa
diff --git a/audio/japa/slack-desc b/audio/japa/slack-desc
new file mode 100644
index 0000000000..4cd4ec592d
--- /dev/null
+++ b/audio/japa/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+japa: japa (audio spectrum analyser for jack-audio-connection-kit)
+japa:
+japa: Japa (JACK and ALSA Perceptual Analyser), is a 'perceptual' or
+japa: 'psychoacoustic' audio spectrum analyser. Possible uses include
+japa: spectrum monitoring while mixing or mastering, evaluation of ambient
+japa: noise, and (using pink noise), equalisation of PA systems.
+japa:
+japa:
+japa:
+japa:
+japa: