summaryrefslogtreecommitdiffstats
path: root/audio/jkmeter
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2014-01-15 09:21:25 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-01-29 23:21:02 -0600
commit5bb964d8199d35ecb397c240ebf78393377b3c7d (patch)
treede2899102cc0a09a6809228a9367660e094ef450 /audio/jkmeter
parentb1caad72a152b6f4918d108a5af116ef3e28dff1 (diff)
downloadslackbuilds-5bb964d8199d35ecb397c240ebf78393377b3c7d.tar.gz
slackbuilds-5bb964d8199d35ecb397c240ebf78393377b3c7d.tar.xz
audio/jkmeter: Added (audio level meter for JACK).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio/jkmeter')
-rw-r--r--audio/jkmeter/README21
-rw-r--r--audio/jkmeter/doinst.sh3
-rw-r--r--audio/jkmeter/jkmeter.179
-rw-r--r--audio/jkmeter/jkmeter.SlackBuild89
-rw-r--r--audio/jkmeter/jkmeter.desktop9
-rw-r--r--audio/jkmeter/jkmeter.info10
-rw-r--r--audio/jkmeter/jkmeter.xpm102
-rw-r--r--audio/jkmeter/setcap.sh1
-rw-r--r--audio/jkmeter/slack-desc19
9 files changed, 333 insertions, 0 deletions
diff --git a/audio/jkmeter/README b/audio/jkmeter/README
new file mode 100644
index 0000000000..daef6793a9
--- /dev/null
+++ b/audio/jkmeter/README
@@ -0,0 +1,21 @@
+jkmeter (audio level meter for JACK)
+
+Jkmeter is a horizontal or vertical bargraph level
+meter based on the ideas of mastering guru Bob Katz. See
+<http://www.digido.com/media/articles-and-demos.html> and follow the
+links on 'level practices'.
+
+This is the type of meter you want for live recording, mixing and
+mastering. It probably makes no sense to use it on all tracks of a DAW,
+where keeping digital level within limits is the main purpose of metering.
+
+By default, the package is built with '-march=native'. If you need a
+generic package that can be installed on any Slackware machine with the
+same ARCH as the build host, set FORCE_SLACK_CFLAGS=yes in the script's
+environment.
+
+This package uses POSIX filesystem capabilities to execute with
+elevated privileges (required for realtime audio processing). This
+may be considered a security/stability risk. Please read
+http://www.slackbuilds.org/caps/ for more information. To disable
+capabilities, pass SETCAP=no to the script.
diff --git a/audio/jkmeter/doinst.sh b/audio/jkmeter/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/audio/jkmeter/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/audio/jkmeter/jkmeter.1 b/audio/jkmeter/jkmeter.1
new file mode 100644
index 0000000000..044a5c2c04
--- /dev/null
+++ b/audio/jkmeter/jkmeter.1
@@ -0,0 +1,79 @@
+.\"
+.\" First parameter, NAME, should be all caps
+.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+.\" other parameters are allowed: see man(7), man(1)
+.TH JKMETER 1 "August 3, 2011"
+.\" Please adjust this date whenever revising the manpage.
+.\"
+.\" Some roff macros, for reference:
+.\" .nh disable hyphenation
+.\" .hy enable hyphenation
+.\" .ad l left justify
+.\" .ad b justify to both left and right margins
+.\" .nf disable filling
+.\" .fi enable filling
+.\" .br insert line break
+.\" .sp <n> insert n+1 empty lines
+.\" for manpage-specific macros, see man(7)
+.SH NAME
+jkmeter \- Jkmeter is a horizontal or vertical bargraph audio level meter for Jack Audio Connection Kit
+.SH SYNOPSIS
+.B jkmeter
+.RI [ options ]
+.br
+.SH DESCRIPTION
+This manual page documents briefly the
+.B jkmeter
+.PP
+.\" TeX users may be more comfortable with the \fB<whatever>\fP and
+.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
+.\" respectively.
+This manual page was written for the Debian distribution because the original program does not have a manual page.
+.PP
+.\" TeX users may be more comfortable with the \fB<whatever>\fP and
+.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
+.\" respectively.
+\fBjkmeter\fP is a horizontal or vertical bargraph level meter based on the ideas of mastering guru Bob Katz. <http://www.digido.com/bob-katz/index.php>
+.br
+ This meter displays both the true RMS level and the digital peak level.
+.SH OPTIONS
+.PP
+.B \ -h
+ Display short info
+.PP
+.B \ -name <name>
+ Name to use as jack client
+.PP
+.B \ -s <server>
+ Jack server name
+.PP
+.B \ -g <geometry>
+ Window position
+.PP
+.B \ -type <type>
+ Meter type, k20 or k14 (k20)
+.PP
+.B \ -rate <rate>
+ Update rate (30)
+.PP
+.B \ -A
+ Ambisonic (4ch) mode
+.PP
+.B \ -C
+ Add correlation meter
+.PP
+.B \ -V
+ Vertical layout
+.PP
+.B \ -H
+ Horizontal layout
+.PP
+.TP
+.SH SEE ALSO
+.BR jackd(1).
+.br
+.SH AUTHOR
+jkmeter was written by Fons Adriaensen <fons@kokkinizita.net>.
+.PP
+This manual page was written by Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
+for the Debian project (but may be used by others).
diff --git a/audio/jkmeter/jkmeter.SlackBuild b/audio/jkmeter/jkmeter.SlackBuild
new file mode 100644
index 0000000000..5c66c9a56c
--- /dev/null
+++ b/audio/jkmeter/jkmeter.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for jkmeter
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=jkmeter
+VERSION=${VERSION:-0.6.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
+ sed -i \
+ -e '/march=native/d' \
+ -e "s,-O2 -ffast-math,$SLKCFLAGS," \
+ source/Makefile
+fi
+
+make -C source PREFIX=/usr DESTDIR=$PKG all install
+strip $PKG/usr/bin/$PRGNAM
+
+# man page, icon, and .desktop file came from Debian
+mkdir -p $PKG/usr/man/man1 $PKG/usr/share/pixmaps $PKG/usr/share/applications
+gzip -9c $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+cat $CWD/$PRGNAM.xpm > $PKG/usr/share/pixmaps/$PRGNAM.xpm
+cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+# Only add capability stuff if not disabled:
+if [ "${SETCAP:-yes}" = "yes" ]; then
+ cat $CWD/setcap.sh >> $PKG/install/doinst.sh
+ # Only allow execution by audio group
+ chown root:audio $PKG/usr/bin/$PRGNAM
+ chmod 0750 $PKG/usr/bin/$PRGNAM
+fi
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/jkmeter/jkmeter.desktop b/audio/jkmeter/jkmeter.desktop
new file mode 100644
index 0000000000..1f924b4d5a
--- /dev/null
+++ b/audio/jkmeter/jkmeter.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Jkmeter
+GenericName=Audio Level Meter
+Comment=Audio level meter for JACK
+Icon=jkmeter32x32
+Exec=jkmeter -C -V
+Terminal=false
+Categories=AudioVideo;Audio;
diff --git a/audio/jkmeter/jkmeter.info b/audio/jkmeter/jkmeter.info
new file mode 100644
index 0000000000..d465cbde81
--- /dev/null
+++ b/audio/jkmeter/jkmeter.info
@@ -0,0 +1,10 @@
+PRGNAM="jkmeter"
+VERSION="0.6.1"
+HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/index.html"
+DOWNLOAD="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/jkmeter-0.6.1.tar.bz2"
+MD5SUM="649cda4465fe070505ae0a1d730b398f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="jack-audio-connection-kit clxclient"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/audio/jkmeter/jkmeter.xpm b/audio/jkmeter/jkmeter.xpm
new file mode 100644
index 0000000000..13a974ebbd
--- /dev/null
+++ b/audio/jkmeter/jkmeter.xpm
@@ -0,0 +1,102 @@
+/* XPM */
+static char *jkmeter_[] = {
+/* columns rows colors chars-per-pixel */
+"32 32 64 1",
+" c #000000000000",
+". c #040404040404",
+"X c #090909090909",
+"o c #0F0F0F0F0F0F",
+"O c #111111111111",
+"+ c #151515151515",
+"@ c #191919191919",
+"# c #1F1F1F1F1F1F",
+"$ c #222222222222",
+"% c #242424242424",
+"& c #282828282828",
+"* c #2F2F2F2F2F2F",
+"= c #333333333333",
+"- c #373737373737",
+"; c #383838383838",
+": c #3F3F3F3F3F3F",
+"> c #424242424242",
+", c #444444444444",
+"< c #4A4A4A4A4A4A",
+"1 c #4F4F4F4F4F4F",
+"2 c #505050505050",
+"3 c #545454545454",
+"4 c #595959595959",
+"5 c #5D5D5D5D5D5D",
+"6 c #626262626262",
+"7 c #646464646464",
+"8 c #696969696969",
+"9 c #6D6D6D6D6D6D",
+"0 c #727272727272",
+"q c #777777777777",
+"w c #7B7B7B7B7B7B",
+"e c #7F7F7F7F7F7F",
+"r c #828282828282",
+"t c #868686868686",
+"y c #8B8B8B8B8B8B",
+"u c #8D8D8D8D8D8D",
+"i c #909090909090",
+"p c #979797979797",
+"a c #999999999999",
+"s c #9F9F9F9F9F9F",
+"d c #A3A3A3A3A3A3",
+"f c #A5A5A5A5A5A5",
+"g c #A8A8A8A8A8A8",
+"h c #AEAEAEAEAEAE",
+"j c #B1B1B1B1B1B1",
+"k c #B5B5B5B5B5B5",
+"l c #BBBBBBBBBBBB",
+"z c #BFBFBFBFBFBF",
+"x c #C2C2C2C2C2C2",
+"c c #C4C4C4C4C4C4",
+"v c #CACACACACACA",
+"b c #CFCFCFCFCFCF",
+"n c #D2D2D2D2D2D2",
+"m c #D4D4D4D4D4D4",
+"M c #D9D9D9D9D9D9",
+"N c #DFDFDFDFDFDF",
+"B c #E0E0E0E0E0E0",
+"V c #E4E4E4E4E4E4",
+"C c #E9E9E9E9E9E9",
+"Z c #EEEEEEEEEEEE",
+"A c #F2F2F2F2F2F2",
+"S c #F4F4F4F4F4F4",
+"D c #F9F9F9F9F9F9",
+"F c #FFFFFFFFFFFF",
+/* pixels */
+"FFFFFFFFFFFFBVFFFFFFFFFFFFFFFFFF",
+"FFFFFFFFFFM; #vFFFFFFFFFFFFFFFF",
+"FFFFFFFFFS@ &FFFFFFFFFFFFFFFF",
+"FFFFFFFFFx FFFFFFFFFFFFFFFF",
+"FFFFFFFFFz DFFFFFFFFFFFFFFF",
+"FFFFFFFFFc DFFFFFFFFFFFFFFF",
+"FFFFFFFFFv FFFFFFFFFFFFFFFF",
+"FFFFFFFFFb DFFFFFFFFFFFFFFF",
+"FFFFFFFFFm DFFFFFFFFFFFFFFF",
+"FFFFFFFFFM DFFFFFFFFFFFFFFF",
+"FFFFFFFFFN FFa->cFFFFFSdinF",
+"FFFFFFFFFV DS >FFFFM& oA",
+"FFFFFFFFFC FZ ;FFFko @S",
+"FFFFFFFFFZ DZ ,FFr -BF",
+"FFFFFFFFFS DZ 1A2 0DFF",
+"FFFFFFFFFD FA ;& OjFFFF",
+"FFFFFFFFFF DZ kFFFFF",
+"FSiqlFFFFA FZ X. OxFFFF",
+"S= &fFFj @FA #cO .gFFF",
+"d $6O 3FZ +Fm$ yFF",
+"n xFZ oFFC= 9F",
+"Fp. qFFZ FFFS< 8",
+"FFb< XuFFFS .FFFFD7 o",
+"FFFFNu2=$*1uCFFFFFp*-sFFFFFFi*;j",
+"FBpSFDfZFFv0qeZVghjlSv0weZFFFFFF",
+"F6 tFt 7FFr.+XzaXX. ir.OXlz670xF",
+"F; #F= &FFu:FFFFF,:SFu:FFFe 1; b",
+"F@2Xi 3 ZFa.#+cFF2*FFa.#@cy VFoy",
+"S 04.Xx jFfow0MFF5$FFfow0Ma %$#N",
+"m wc <S wFjosaMFF8+FFjospMf : pF",
+"m.kF;dF-1FnX 8FFu#FFnX 8k l4 u",
+"FDFFDFFZAFFFFFFFFFDFFFFFFFmXbD,:"
+};
diff --git a/audio/jkmeter/setcap.sh b/audio/jkmeter/setcap.sh
new file mode 100644
index 0000000000..bb6a6b0f5e
--- /dev/null
+++ b/audio/jkmeter/setcap.sh
@@ -0,0 +1 @@
+[ -x /sbin/setcap ] && /sbin/setcap cap_ipc_lock,cap_sys_nice=ep usr/bin/jkmeter
diff --git a/audio/jkmeter/slack-desc b/audio/jkmeter/slack-desc
new file mode 100644
index 0000000000..b4afcb54bd
--- /dev/null
+++ b/audio/jkmeter/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+jkmeter: jkmeter (audio level meter for JACK)
+jkmeter:
+jkmeter: Jkmeter is a horizontal or vertical bargraph level
+jkmeter: meter based on the ideas of mastering guru Bob Katz.
+jkmeter: See <http://www.digido.com/bob-katz/index.php> and
+jkmeter: follow the links on 'level practices'.
+jkmeter:
+jkmeter:
+jkmeter:
+jkmeter:
+jkmeter: