summaryrefslogtreecommitdiffstats
path: root/desktop/redshift
diff options
context:
space:
mode:
author ArTourter <artourter@gmail.com>2017-07-01 07:38:29 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-01 07:38:29 +0700
commit778768445eef074bd93dd62288dd792d27626af5 (patch)
treed18b93197acab61842f316de67e85bf5125ef6aa /desktop/redshift
parent6a950ab801b4357630370c2fc48d3caf1adef728 (diff)
downloadslackbuilds-778768445eef074bd93dd62288dd792d27626af5.tar.gz
slackbuilds-778768445eef074bd93dd62288dd792d27626af5.tar.xz
desktop/redshift: allow compilation against geoclue2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/redshift')
-rw-r--r--desktop/redshift/README6
-rw-r--r--desktop/redshift/redshift.SlackBuild17
2 files changed, 10 insertions, 13 deletions
diff --git a/desktop/redshift/README b/desktop/redshift/README
index f5aa4f2e3c..540fcd8ab8 100644
--- a/desktop/redshift/README
+++ b/desktop/redshift/README
@@ -1,7 +1,7 @@
redshift (screen colour adjuster)
Redshift adjusts the colour temperature of your screen according to
-your surroundings. This may help your eyes if you are working in front
-of the screen at night.
+your surroundings. This may help your eyes if you are working in
+front of the screen at night.
-geoclue is an optional dependency.
+This package has an optional dependency on geoclue and/or geoclue2.
diff --git a/desktop/redshift/redshift.SlackBuild b/desktop/redshift/redshift.SlackBuild
index 4387b0fb6e..52adf1313d 100644
--- a/desktop/redshift/redshift.SlackBuild
+++ b/desktop/redshift/redshift.SlackBuild
@@ -7,7 +7,7 @@
PRGNAM=redshift
VERSION=${VERSION:-1.11}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -47,25 +47,22 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-CLUE=""
-if ! pkg-config --exists geoclue; then
- CLUE="--disable-geoclue2"
+if ! pkg-config --exists geoclue-2.0
+then
+ CLUE2="--disable-geoclue2"
fi
-sed -i -e 's/gtk-update-icon-cache.*|| //' Makefile.am
-
# build redshift-gtk, forcing python2
# thanks to the fedora project for the patch
sed -i 's/\(AM_PATH_PYTHON(\[\)3\.2/\12.7/' configure.ac
sed -i 's/\(env python\)3/\1/' src/redshift-gtk/redshift-gtk.in
autopoint -f && AUTOPOINT="intltoolize --automake --copy" autoreconf -vif
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -75,8 +72,8 @@ CXXFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
+ $CLUE2 \
--docdir=/usr/doc/$PRGNAM-$VERSION \
- $CLUE \
--build=$ARCH-slackware-linux
make