summaryrefslogtreecommitdiffstats
path: root/desktop/redshift
diff options
context:
space:
mode:
author ArTourter <artourter@gmail.com>2017-06-02 22:47:37 +0100
committer David Spencer <idlemoor@slackbuilds.org>2017-06-02 22:48:01 +0100
commit8ec8651051f1278ed5076bfe464d4decc8729d6c (patch)
treeec455d0febbd93b78bbc62f0f07488bac4b002a1 /desktop/redshift
parent58db60d06c9e8e24a1118d88f64f637b27e2ad15 (diff)
downloadslackbuilds-8ec8651051f1278ed5076bfe464d4decc8729d6c.tar.gz
slackbuilds-8ec8651051f1278ed5076bfe464d4decc8729d6c.tar.xz
desktop/redshift: Updated for version 1.11 + new maintainer.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'desktop/redshift')
-rw-r--r--desktop/redshift/README7
-rw-r--r--desktop/redshift/doinst.sh5
-rw-r--r--desktop/redshift/redshift.SlackBuild31
-rw-r--r--desktop/redshift/redshift.info10
4 files changed, 35 insertions, 18 deletions
diff --git a/desktop/redshift/README b/desktop/redshift/README
index c85453d5ac..f5aa4f2e3c 100644
--- a/desktop/redshift/README
+++ b/desktop/redshift/README
@@ -1,8 +1,7 @@
redshift (screen colour adjuster)
Redshift adjusts the colour temperature of your screen according to
-your surroundings. This may help your eyes if you are working in
-front of the screen at night.
+your surroundings. This may help your eyes if you are working in front
+of the screen at night.
-For more information, see:
-http://jonls.dk/redshift/
+geoclue is an optional dependency.
diff --git a/desktop/redshift/doinst.sh b/desktop/redshift/doinst.sh
index 19400050fd..65c7e2eeb9 100644
--- a/desktop/redshift/doinst.sh
+++ b/desktop/redshift/doinst.sh
@@ -1,6 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
if [ -x /usr/bin/gtk-update-icon-cache ]; then
/usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
fi
fi
-
diff --git a/desktop/redshift/redshift.SlackBuild b/desktop/redshift/redshift.SlackBuild
index e42eb39268..4387b0fb6e 100644
--- a/desktop/redshift/redshift.SlackBuild
+++ b/desktop/redshift/redshift.SlackBuild
@@ -2,16 +2,17 @@
# Slackware build script for redshift
# Written by David Matthew Jerry Koenig <koenigdavidmj@gmail.com>
+# Maintained by Gregory Tourte <artourter@gmail.com> since 2017
# Public domain, written 2010.
PRGNAM=redshift
-VERSION=${VERSION:-1.8}
+VERSION=${VERSION:-1.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -22,8 +23,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -42,14 +43,28 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CLUE=""
+if ! pkg-config --exists geoclue; then
+ CLUE="--disable-geoclue2"
+fi
+
+sed -i -e 's/gtk-update-icon-cache.*|| //' Makefile.am
+
+# build redshift-gtk, forcing python2
+# thanks to the fedora project for the patch
+sed -i 's/\(AM_PATH_PYTHON(\[\)3\.2/\12.7/' configure.ac
+sed -i 's/\(env python\)3/\1/' src/redshift-gtk/redshift-gtk.in
+autopoint -f && AUTOPOINT="intltoolize --automake --copy" autoreconf -vif
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -61,6 +76,7 @@ CXXFLAGS="$SLKCFLAGS" \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
+ $CLUE \
--build=$ARCH-slackware-linux
make
@@ -73,7 +89,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING AUTHORS README NEWS INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING DESIGN HACKING README NEWS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -82,4 +98,3 @@ cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-
diff --git a/desktop/redshift/redshift.info b/desktop/redshift/redshift.info
index 3ff470ab90..8b8780b5a3 100644
--- a/desktop/redshift/redshift.info
+++ b/desktop/redshift/redshift.info
@@ -1,10 +1,10 @@
PRGNAM="redshift"
-VERSION="1.8"
+VERSION="1.11"
HOMEPAGE="http://jonls.dk/redshift/"
-DOWNLOAD="https://github.com/jonls/redshift/releases/download/v1.8/redshift-1.8.tar.bz2"
-MD5SUM="a05c34bc7b8fbb4f5d546a0b5cca5d6f"
+DOWNLOAD="https://github.com/jonls/redshift/releases/download/v1.11/redshift-1.11.tar.xz"
+MD5SUM="a31d768b0348c5202e58612855a9027e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pyxdg"
-MAINTAINER="David Matthew Jerry Koenig"
-EMAIL="koenigdavidmj@gmail.com"
+MAINTAINER="ArTourter"
+EMAIL="artourter@gmail.com"