summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2011-03-16 00:57:15 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-03-16 00:57:15 -0500
commit9b410b93533515b9456fa65f08b2aed614e489a7 (patch)
tree6641d2b2080c2703b68f995f3845757f89984706 /desktop
parent7688ed87ff6090c9c3e331278891e9fe00462681 (diff)
downloadslackbuilds-9b410b93533515b9456fa65f08b2aed614e489a7.tar.gz
slackbuilds-9b410b93533515b9456fa65f08b2aed614e489a7.tar.xz
desktop/fusion-icon: Removed (unmaintained)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/fusion-icon/README18
-rw-r--r--desktop/fusion-icon/README.POST_INSTALL10
-rw-r--r--desktop/fusion-icon/doinst.sh7
-rw-r--r--desktop/fusion-icon/fusion-icon.SlackBuild70
-rw-r--r--desktop/fusion-icon/fusion-icon.info10
-rw-r--r--desktop/fusion-icon/slack-desc19
6 files changed, 0 insertions, 134 deletions
diff --git a/desktop/fusion-icon/README b/desktop/fusion-icon/README
deleted file mode 100644
index e0b8a06a31..0000000000
--- a/desktop/fusion-icon/README
+++ /dev/null
@@ -1,18 +0,0 @@
-Fusion Icon is a simple system tray applet for starting and controlling
-Compiz Fusion. Upon launch, it will attempt to start Compiz Fusion
-automatically. You may need to select a window decorator if one does not
-appear.
-
-For correct installation, build in this order:
- 1. compiz-bcop
- 2. protobuf (optional but recommended)
- 3. libcompizconfig
- 4. compizconfig-python
- 5. compizconfig-backend-kconfig4 (optional)
- 6. ccsm
- 7. compiz-plugins-main
- 8. compiz-plugins-extra (optional)
- 9. compiz-plugins-unsupported (optional)
-10. emerald (optional)
-11. emerald-themes (optional)
-12. fusion-icon (optional)
diff --git a/desktop/fusion-icon/README.POST_INSTALL b/desktop/fusion-icon/README.POST_INSTALL
deleted file mode 100644
index 3c8f207a68..0000000000
--- a/desktop/fusion-icon/README.POST_INSTALL
+++ /dev/null
@@ -1,10 +0,0 @@
-After you've installed the compiz-fusion packages you need to enable
-a few key features before you launch compiz.
-Launch "ccsm" and enable the following options:
-
- * Window Decorations
- * Move Window
- * Rezise Window
-
-These options will allow you to manage your windows.
-After enabled, you can launch compiz and customize to your liking.
diff --git a/desktop/fusion-icon/doinst.sh b/desktop/fusion-icon/doinst.sh
deleted file mode 100644
index a61bc59590..0000000000
--- a/desktop/fusion-icon/doinst.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f -t usr/share/icons/hicolor >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
-fi
diff --git a/desktop/fusion-icon/fusion-icon.SlackBuild b/desktop/fusion-icon/fusion-icon.SlackBuild
deleted file mode 100644
index 79deb70239..0000000000
--- a/desktop/fusion-icon/fusion-icon.SlackBuild
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for fusion-icon
-
-# Written by M.Dinslage (daedra1980@gmail.com)
-
-PRGNAM=fusion-icon
-VERSION=${VERSION:-20100612}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- SLKLDFLAGS="-L/usr/lib64"; LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- SLKLDFLAGS=""; LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM.tar.gz
-cd $PRGNAM
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --prefix=/usr --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING VERSION \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/fusion-icon/fusion-icon.info b/desktop/fusion-icon/fusion-icon.info
deleted file mode 100644
index 030d78a908..0000000000
--- a/desktop/fusion-icon/fusion-icon.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="fusion-icon"
-VERSION="20100612"
-HOMEPAGE="http://www.compiz.org"
-DOWNLOAD="http://webpages.charter.net/daedra1/fusion-icon.tar.gz"
-MD5SUM="df69969a8e55627ea1ccebc63ec64f95"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="M.Dinslage"
-EMAIL="daedra1980@gmail.com"
-APPROVED="Erik Hanson"
diff --git a/desktop/fusion-icon/slack-desc b/desktop/fusion-icon/slack-desc
deleted file mode 100644
index 77d12320ee..0000000000
--- a/desktop/fusion-icon/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-fusion-icon: fusion-icon (A system tray tool for Compiz Fusion)
-fusion-icon:
-fusion-icon: Fusion Icon is a system tray tool to manage Compiz Fusion.
-fusion-icon:
-fusion-icon:
-fusion-icon:
-fusion-icon:
-fusion-icon:
-fusion-icon:
-fusion-icon:
-fusion-icon: