summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Markus Rinne <markus.ka.rinne@gmail.com>2017-11-16 22:03:04 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-11-18 12:40:30 +0700
commit00b597da86a5f05690b8a7bd53d5dec6a8c3e5d3 (patch)
tree60c7d24b9631d3a0cdc1987d7fd7cf5fa11e8fdf /development
parent81e740d4fc893370ed5fc2c29cefb01658e5e919 (diff)
downloadslackbuilds-00b597da86a5f05690b8a7bd53d5dec6a8c3e5d3.tar.gz
slackbuilds-00b597da86a5f05690b8a7bd53d5dec6a8c3e5d3.tar.xz
development/robotframework: Added (acceptance test framework).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/robotframework/README6
-rw-r--r--development/robotframework/robotframework.SlackBuild87
-rw-r--r--development/robotframework/robotframework.info10
-rw-r--r--development/robotframework/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/development/robotframework/README b/development/robotframework/README
new file mode 100644
index 0000000000..e31dff8446
--- /dev/null
+++ b/development/robotframework/README
@@ -0,0 +1,6 @@
+Robot Framework is a generic test automation framework for acceptance testing
+and acceptance test-driven development (ATDD). It has easy-to-use tabular
+test data syntax and it utilizes the keyword-driven testing approach. Its
+testing capabilities can be extended by test libraries implemented either with
+Python or Java, and users can create new higher-level keywords from existing
+ones using the same syntax that is used for creating test cases.
diff --git a/development/robotframework/robotframework.SlackBuild b/development/robotframework/robotframework.SlackBuild
new file mode 100644
index 0000000000..96af9a6d90
--- /dev/null
+++ b/development/robotframework/robotframework.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for robotframework
+
+# Copyright 2017 Markus Rinne Finland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=robotframework
+VERSION=${VERSION:-3.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYRIGHT.txt AUTHORS.txt LICENSE.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/robotframework/robotframework.info b/development/robotframework/robotframework.info
new file mode 100644
index 0000000000..db87cf67ec
--- /dev/null
+++ b/development/robotframework/robotframework.info
@@ -0,0 +1,10 @@
+PRGNAM="robotframework"
+VERSION="3.0.2"
+HOMEPAGE="http://robotframework.org/"
+DOWNLOAD="https://github.com/robotframework/robotframework/archive/3.0.2/robotframework-3.0.2.tar.gz"
+MD5SUM="42200db321356636d407843d894bc457"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Markus Rinne"
+EMAIL="markus.ka.rinne@gmail.com"
diff --git a/development/robotframework/slack-desc b/development/robotframework/slack-desc
new file mode 100644
index 0000000000..e5e119ef3e
--- /dev/null
+++ b/development/robotframework/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+robotframework: robotframework (test automation framework for acceptance testing)
+robotframework:
+robotframework: Robot Framework is a generic test automation framework for acceptance
+robotframework: testing and acceptance test-driven development (ATDD). It has
+robotframework: easy-to-use tabular test data syntax and it utilizes the
+robotframework: keyword-driven testing approach. Its testing capabilities can be
+robotframework: extended by test libraries implemented either with Python or Java, and
+robotframework: users can create new higher-level keywords from existing ones using
+robotframework: the same syntax that is used for creating test cases.
+robotframework:
+robotframework: