summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Azure Zanculmarktum <zanculmarktum@gmail.com>2018-03-27 15:14:46 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-31 07:41:38 +0700
commitce7e1d43e4286bdc8a6d49e7a7c102e72a37868d (patch)
tree159a0908caa74e40bf2f0be4504012524cc1813e /development
parent40c8f28364f1191c9448f175894b5b0695f6b831 (diff)
downloadslackbuilds-ce7e1d43e4286bdc8a6d49e7a7c102e72a37868d.tar.gz
slackbuilds-ce7e1d43e4286bdc8a6d49e7a7c102e72a37868d.tar.xz
development/lua52: Added (scripting language).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/lua52/README6
-rw-r--r--development/lua52/lua.pc.in31
-rw-r--r--development/lua52/lua52.SlackBuild150
-rw-r--r--development/lua52/lua52.info10
-rw-r--r--development/lua52/slack-desc19
5 files changed, 216 insertions, 0 deletions
diff --git a/development/lua52/README b/development/lua52/README
new file mode 100644
index 0000000000..c0cc2f7a96
--- /dev/null
+++ b/development/lua52/README
@@ -0,0 +1,6 @@
+Lua is a free software light-weight programming language designed for
+extending applications. Lua is also frequently used as a
+general-purpose, stand-alone scripting language.
+
+This package contains lua version 5.2.x that won't conflicts with lua
+version 5.1.x and 5.3.x
diff --git a/development/lua52/lua.pc.in b/development/lua52/lua.pc.in
new file mode 100644
index 0000000000..07e2852b0a
--- /dev/null
+++ b/development/lua52/lua.pc.in
@@ -0,0 +1,31 @@
+# lua.pc -- pkg-config data for Lua
+
+# vars from install Makefile
+
+# grep '^V=' ../Makefile
+V= 5.1
+# grep '^R=' ../Makefile
+R= 5.1.5
+
+# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
+prefix= /usr/local
+INSTALL_BIN= ${prefix}/bin
+INSTALL_INC= ${prefix}/include
+INSTALL_LIB= ${prefix}/lib
+INSTALL_MAN= ${prefix}/man/man1
+INSTALL_LMOD= ${prefix}/share/lua/${V}
+INSTALL_CMOD= ${prefix}/lib/lua/${V}
+
+# canonical vars
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: Lua
+Description: An Extensible Extension Language
+Version: ${R}
+Requires:
+Libs: -L${libdir} -llua -lm
+Cflags: -I${includedir}
+
+# (end of lua.pc)
diff --git a/development/lua52/lua52.SlackBuild b/development/lua52/lua52.SlackBuild
new file mode 100644
index 0000000000..6b50862bc7
--- /dev/null
+++ b/development/lua52/lua52.SlackBuild
@@ -0,0 +1,150 @@
+#!/bin/sh
+
+# Slackware build script for lua52
+
+# Copyright 2018 Azure Zanculmarktum <zanculmarktum@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Some of the codes were taken from development/lua/lua.SlackBuild
+
+PRGNAM=lua52
+SRCNAM=${PRGNAM%??}
+VERSION=${VERSION:-5.2.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+eval $(sed -ne '/^\(V\|R\)= /s, ,,p' Makefile)
+
+sed -i \
+ -e '/^INSTALL_TOP= /s,\(/usr\).*,\$(DESTDIR)\1,' \
+ -e '/^INSTALL_INC= /s,include,&/lua\$V,' \
+ -e '/^INSTALL_LIB= /s,lib,&'"${LIBDIRSUFFIX}"',' \
+ -e '/^INSTALL_CMOD= /s,lib,&'"${LIBDIRSUFFIX}"',' \
+ -e '/^TO_BIN= /s,luac\?,&\$V,g' \
+ -e '/^TO_LIB= /s,liblua,&\$V,' \
+ Makefile
+
+sed -i \
+ -e '/^CFLAGS= /s,-O2,'"$SLKCFLAGS"',' \
+ -e '/-DLUA_USE_LINUX.*-Wl,-E -ldl -lreadline/s|-lreadline|& -lncurses|' \
+ -e '/^LUA_A=/s,liblua,&'"$V"',' \
+ -e '/^LUA_T=/s,lua,&'"$V"',' \
+ -e '/^LUAC_T=/s,luac,&'"$V"',' \
+ src/Makefile
+
+sed -i \
+ -e '/^#define LUA_ROOT/s,".*,"/usr",' \
+ -e '/^#define LUA_CDIR/s,"lib,&'"${LIBDIRSUFFIX}"',' \
+ src/luaconf.h
+
+make linux
+make install DESTDIR=$PKG
+
+# Now let's build the shared library
+mkdir -p shared
+cd shared
+ ar -x $PKG/usr/lib${LIBDIRSUFFIX}/liblua$V.a
+ gcc -ldl -lreadline -lncurses -lm -shared *.o -o liblua$V.so.$R
+ cp -a liblua$V.so.$R $PKG/usr/lib${LIBDIRSUFFIX}
+ ( cd $PKG/usr/lib${LIBDIRSUFFIX}
+ ln -s liblua$V.so.$R liblua$V.so.$V
+ ln -s liblua$V.so.$R liblua$V.so.${V%??}
+ ln -s liblua$V.so.$R liblua$V.so
+ )
+cd - >/dev/null
+
+mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
+cd $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
+ sed \
+ -e '/^V= /s, .*, '"$V"',' \
+ -e '/^R= /s, .*, '"$R"',' \
+ -e '/^prefix= /s,\(/usr\).*,\1,' \
+ -e '/^INSTALL_INC= /s,include,&/lua\${V},' \
+ -e '/^INSTALL_LIB= /s,lib,&'"${LIBDIRSUFFIX}"',' \
+ -e '/^INSTALL_CMOD= /s,lib,&'"${LIBDIRSUFFIX}"',' \
+ -e '/^libdir=/s,/lib,&'"${LIBDIRSUFFIX}"',' \
+ -e '/^includedir=/s,/include,&/lua\${V},' \
+ $CWD/lua.pc.in > lua$V.pc
+ ln -s lua$V.pc lua-$V.pc
+ ln -s lua$V.pc lua${V%.?}${V#?.}.pc
+cd - >/dev/null
+
+cd $PKG/usr/man/man1
+ mv lua.1 lua$V.1
+ mv luac.1 luac$V.1
+cd - >/dev/null
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/lua52/lua52.info b/development/lua52/lua52.info
new file mode 100644
index 0000000000..40327972a8
--- /dev/null
+++ b/development/lua52/lua52.info
@@ -0,0 +1,10 @@
+PRGNAM="lua52"
+VERSION="5.2.4"
+HOMEPAGE="https://www.lua.org/"
+DOWNLOAD="https://www.lua.org/ftp/lua-5.2.4.tar.gz"
+MD5SUM="913fdb32207046b273fdb17aad70be13"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Azure Zanculmarktum"
+EMAIL="zanculmarktum@gmail.com"
diff --git a/development/lua52/slack-desc b/development/lua52/slack-desc
new file mode 100644
index 0000000000..59274116d4
--- /dev/null
+++ b/development/lua52/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+lua52: lua52 (powerful, fast, light-weight, embeddable scripting language)
+lua52:
+lua52: This package contains lua version 5.2.x that won't conflicts with lua
+lua52: version 5.1.x and 5.3.x
+lua52:
+lua52:
+lua52:
+lua52:
+lua52:
+lua52:
+lua52: