summaryrefslogtreecommitdiffstats
path: root/games/SpaceZero
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-09-20 17:57:14 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-09-24 07:05:14 +0700
commit3a6845092fa639c81812f52c97c227c92d3d4ee4 (patch)
tree0f199f30a2dce0767717fdba76402785da1b740f /games/SpaceZero
parenta2f6c1f9cf4669903783ba219296fbc5ab67ec8a (diff)
downloadslackbuilds-3a6845092fa639c81812f52c97c227c92d3d4ee4.tar.gz
slackbuilds-3a6845092fa639c81812f52c97c227c92d3d4ee4.tar.xz
games/SpaceZero: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'games/SpaceZero')
-rw-r--r--games/SpaceZero/SpaceZero.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/SpaceZero/SpaceZero.SlackBuild b/games/SpaceZero/SpaceZero.SlackBuild
index 85acc32c8b..dfa404461a 100644
--- a/games/SpaceZero/SpaceZero.SlackBuild
+++ b/games/SpaceZero/SpaceZero.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for SpaceZero
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -30,7 +30,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -68,7 +68,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/Makefile.patch