summaryrefslogtreecommitdiffstats
path: root/games/SpaceZero
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-04-10 07:34:12 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-04-10 07:34:12 +0700
commit54201de6cf4bd5f4a94ba4db8dd2e156b5446014 (patch)
treee9c9eda5602301a8da5ce0a42f662bd719288ec1 /games/SpaceZero
parentbc3a95bf5d210c7533523ea89a5df1cd122817c0 (diff)
downloadslackbuilds-54201de6cf4bd5f4a94ba4db8dd2e156b5446014.tar.gz
slackbuilds-54201de6cf4bd5f4a94ba4db8dd2e156b5446014.tar.xz
games/SpaceZero: Added (space game).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/SpaceZero')
-rw-r--r--games/SpaceZero/Makefile.patch25
-rw-r--r--games/SpaceZero/README5
-rw-r--r--games/SpaceZero/SpaceZero.SlackBuild102
-rw-r--r--games/SpaceZero/SpaceZero.desktop10
-rw-r--r--games/SpaceZero/SpaceZero.info10
-rw-r--r--games/SpaceZero/doinst.sh3
-rw-r--r--games/SpaceZero/slack-desc19
-rw-r--r--games/SpaceZero/spacezero.pngbin0 -> 1506 bytes
8 files changed, 174 insertions, 0 deletions
diff --git a/games/SpaceZero/Makefile.patch b/games/SpaceZero/Makefile.patch
new file mode 100644
index 0000000000..4d9fab2351
--- /dev/null
+++ b/games/SpaceZero/Makefile.patch
@@ -0,0 +1,25 @@
+--- spacezero/Makefile.original 2014-04-07 20:07:25.673407307 +0300
++++ spacezero/Makefile 2014-04-07 20:08:30.901591842 +0300
+@@ -9,11 +9,11 @@
+ RECORDFILE=$(CONFIGDIR)/record
+
+ # The binary executable will be copied in the next directory.
+-INSTALL_DIR=/usr/local/games
++INSTALL_DIR=/usr/bin
+
+ # All data files will be copied in the next directory.
+ # tar.gz
+-INSTALL_DATA_DIR=/usr/local/share/spacezero
++INSTALL_DATA_DIR=/usr/share/games/SpaceZero
+
+ # DEB pkg
+ #INSTALL_DIR=/usr/games
+@@ -27,7 +27,7 @@
+ GTKFLAGS12=`gtk-config --libs`
+
+ CFLAGS= -Wall -O3 --pedantic -I./include -DDATADIR=\"$(DATADIR)\" -DINSTALL_DATA_DIR=\"$(INSTALL_DATA_DIR)\"
+-LDFLAGS= -lm -lpthread $(SOUNDFLAGS) $(GTKLIBS)
++LDFLAGS= -lm -lpthread -lX11 -lXext -ldl $(SOUNDFLAGS) $(GTKLIBS)
+
+ # DEB pkg
+ #CFLAGS += `dpkg-buildflags --get CFLAGS`
diff --git a/games/SpaceZero/README b/games/SpaceZero/README
new file mode 100644
index 0000000000..00158865d2
--- /dev/null
+++ b/games/SpaceZero/README
@@ -0,0 +1,5 @@
+SpaceZero is a RTS 2D space combat, single and multiplayer
+(two players by now) net game. Your objective is to conquer
+all space. At the starting point the player owns a spaceship
+which has landed on a planet. Your first task is to acquire
+new spaceships and find new planets in the Galaxy.
diff --git a/games/SpaceZero/SpaceZero.SlackBuild b/games/SpaceZero/SpaceZero.SlackBuild
new file mode 100644
index 0000000000..85acc32c8b
--- /dev/null
+++ b/games/SpaceZero/SpaceZero.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/sh
+
+# Slackware build script for SpaceZero
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=SpaceZero
+SRCNAM=spacezero
+VERSION=${VERSION:-0.86.00}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/Makefile.patch
+
+make
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/bin \
+ $PKG/usr/share/games/$PRGNAM/{locales,sounds}
+
+install -D -m0644 dat/locales/* $PKG/usr/share/games/$PRGNAM/locales
+install -D -m0644 dat/sounds/* $PKG/usr/share/games/$PRGNAM/sounds
+install -D -m0755 bin/$SRCNAM $PKG/usr/bin/$SRCNAM
+
+mkdir -p $PKG/usr/share/applications
+install -D -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+
+mkdir -p $PKG/usr/share/pixmaps/
+install -D -m644 $CWD/$SRCNAM.png $PKG/usr/share/pixmaps/$SRCNAM.svg
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a html/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/SpaceZero/SpaceZero.desktop b/games/SpaceZero/SpaceZero.desktop
new file mode 100644
index 0000000000..1c2f84774a
--- /dev/null
+++ b/games/SpaceZero/SpaceZero.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name= SpaceZero
+Name[he]= SpaceZero
+Comment= A 2D Real Time Strategy space combat game
+Exec=spacezero
+Icon=spacezero
+Terminal=false
+Type=Application
+Categories=Game;SpaceGame;
+GenericName=Game
diff --git a/games/SpaceZero/SpaceZero.info b/games/SpaceZero/SpaceZero.info
new file mode 100644
index 0000000000..dd7da2363c
--- /dev/null
+++ b/games/SpaceZero/SpaceZero.info
@@ -0,0 +1,10 @@
+PRGNAM="SpaceZero"
+VERSION="0.86.00"
+HOMEPAGE="http://spacezero.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/project/spacezero/spacezero%200.86/spacezero-0.86.00.tar.gz"
+MD5SUM="4fe4e3c95ba08198751c382fdaa106e2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="freealut"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/games/SpaceZero/doinst.sh b/games/SpaceZero/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/games/SpaceZero/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/games/SpaceZero/slack-desc b/games/SpaceZero/slack-desc
new file mode 100644
index 0000000000..d9fdd11c00
--- /dev/null
+++ b/games/SpaceZero/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+SpaceZero: SpaceZero (space game)
+SpaceZero:
+SpaceZero: SpaceZero is a Real Time Strategy 2D space combat game for two
+SpaceZero: players over a network. The objective is to conquer the universe,
+SpaceZero: defeating all enemies. At starting point you have only one ship and
+SpaceZero: one planet, but you have gold to buy more ships to conquer more
+SpaceZero: planets.
+SpaceZero:
+SpaceZero: Homepage: http://spacezero.sourceforge.net/
+SpaceZero:
+SpaceZero:
diff --git a/games/SpaceZero/spacezero.png b/games/SpaceZero/spacezero.png
new file mode 100644
index 0000000000..4fa9701849
--- /dev/null
+++ b/games/SpaceZero/spacezero.png
Binary files differ