summaryrefslogtreecommitdiffstats
path: root/games/astromenace
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2015-09-25 06:07:42 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-09-26 10:05:39 +0700
commitc54667349413746682968702b40a07c38a0c9b92 (patch)
treeb3ac5baf0b4a3b8a303b97b5aab8b9ba52c8f125 /games/astromenace
parentd09db4855ea793521b8a897645b39f1ac5aba33c (diff)
downloadslackbuilds-c54667349413746682968702b40a07c38a0c9b92.tar.gz
slackbuilds-c54667349413746682968702b40a07c38a0c9b92.tar.xz
games/astromenace: Added patch for newer freetype2.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'games/astromenace')
-rw-r--r--games/astromenace/astromenace.SlackBuild7
-rw-r--r--games/astromenace/ft2_path.patch11
2 files changed, 16 insertions, 2 deletions
diff --git a/games/astromenace/astromenace.SlackBuild b/games/astromenace/astromenace.SlackBuild
index a85d308613..75264f496e 100644
--- a/games/astromenace/astromenace.SlackBuild
+++ b/games/astromenace/astromenace.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for AstroMenace
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2015 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
SRCNAM=astromenace-src
PRGNAM=$(echo $SRCNAM | cut -c1-11)
VERSION=${VERSION:-1.3.2}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,6 +70,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix freetype2 header path
+patch -p1 < $CWD/ft2_path.patch
+
mkdir -p build
cmake ./ # create Makefile
make # build game
diff --git a/games/astromenace/ft2_path.patch b/games/astromenace/ft2_path.patch
new file mode 100644
index 0000000000..ecae574d4c
--- /dev/null
+++ b/games/astromenace/ft2_path.patch
@@ -0,0 +1,11 @@
+--- AstroMenace/CMakeLists.orig.txt 2015-09-25 05:48:58.014083691 +0300
++++ AstroMenace/CMakeLists.txt 2015-09-25 05:59:11.322416282 +0300
+@@ -192,7 +192,7 @@
+ ELSE(FREETYPE_LIBRARY)
+ MESSAGE(FATAL_ERROR "freetype not found")
+ ENDIF(FREETYPE_LIBRARY)
+-FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
++FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 /usr/include/freetype2/config/ftheader.h
+ HINTS
+ $ENV{FREETYPE_DIR}/include/freetype2
+ PATHS