summaryrefslogtreecommitdiffstats
path: root/games/mars
diff options
context:
space:
mode:
author David Spencer <idlemoor@slackbuilds.org>2016-04-10 09:44:20 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-04-12 17:34:23 +0700
commiteccef44bb7964b6415bc4df49c3f91670dac1243 (patch)
tree052376b5a21d406e7a7924bb4629810aaa727985 /games/mars
parenta17aec6a688dbffb773aba4d424351b7679610fe (diff)
downloadslackbuilds-eccef44bb7964b6415bc4df49c3f91670dac1243.tar.gz
slackbuilds-eccef44bb7964b6415bc4df49c3f91670dac1243.tar.xz
games/mars: Fixed build with fribidi-0.19.7.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'games/mars')
-rw-r--r--games/mars/mars.SlackBuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/games/mars/mars.SlackBuild b/games/mars/mars.SlackBuild
index 52a64dbb4f..9db950fd9a 100644
--- a/games/mars/mars.SlackBuild
+++ b/games/mars/mars.SlackBuild
@@ -78,11 +78,17 @@ patch -p1 < $CWD/pull2.patch
# https://github.com/thelaui/M.A.R.S./pull/17
patch -p1 < $CWD/pull17.patch
+# Fix build with fribidi-0.19.7 ...
+FRIBIDIFLAGS=$(pkg-config --cflags fribidi)
+# ... and use our bloody cxxflags, thanks all the same
+sed -i \
+ -e 's/set(CMAKE_CXX_FLAGS "-s -O2")/set(CMAKE_CXX_FLAGS "-s ${CMAKE_CXX_FLAGS}")/' \
+ CMakeLists.txt
+
mkdir -p build
cd build
cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS $FRIBIDIFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
make