summaryrefslogtreecommitdiffstats
path: root/games/sl
diff options
context:
space:
mode:
author V'yacheslav Stetskevych <slava18@gmail.com>2010-05-13 00:58:12 +0200
committer Michiel van Wessem <michiel@slackbuilds.org>2010-05-13 00:58:12 +0200
commit9af28a6a5cc24cc77ce3a2c1f9894f4b6fd11f41 (patch)
tree73ed894e166bebf9e85a2c533a08d7df361b8175 /games/sl
parent944810459a183059ed1c10c7e2c27ee037ac9b44 (diff)
downloadslackbuilds-9af28a6a5cc24cc77ce3a2c1f9894f4b6fd11f41.tar.gz
slackbuilds-9af28a6a5cc24cc77ce3a2c1f9894f4b6fd11f41.tar.xz
games/sl: Added to 13.0 repository
Diffstat (limited to 'games/sl')
-rw-r--r--games/sl/README10
-rw-r--r--games/sl/sl.SlackBuild95
-rw-r--r--games/sl/sl.info12
-rw-r--r--games/sl/slack-desc19
4 files changed, 136 insertions, 0 deletions
diff --git a/games/sl/README b/games/sl/README
new file mode 100644
index 0000000000..33b35e724d
--- /dev/null
+++ b/games/sl/README
@@ -0,0 +1,10 @@
+Sl is a program that can display animations aimed to correct you if
+you type sl instead of ls by mistake. Sl stands for Steam Locomotive.
+
+As the original version of this program is no longer maintained,
+this build uses the Debian patchset to bring it up-to-date.
+
+Original homepage:
+http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html
+Patchset:
+http://packages.debian.org/squeeze/sl
diff --git a/games/sl/sl.SlackBuild b/games/sl/sl.SlackBuild
new file mode 100644
index 0000000000..a1ddaa0d2d
--- /dev/null
+++ b/games/sl/sl.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+
+# Slackware build script for sl.
+# This script builds the version of sl maintained by the Debian project.
+
+# Written by V'yacheslav Stetskevych
+
+PRGNAM=sl
+VERSION=${VERSION:-3.03}
+PATCHLEVEL=${PATCHLEVEL:-16}
+SRCVERSION=${SRCVERSION:-3.03.orig}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVERSION
+tar xvf $CWD/${PRGNAM}_$SRCVERSION.tar.gz
+cd $PRGNAM-$SRCVERSION
+# Apply the debian patchset, which creates the "debian" directory
+echo "Applying debian patchset..."
+zcat $CWD/sl_$VERSION-$PATCHLEVEL.diff.gz | patch -p1
+# Apply individual debian patches
+echo "Patching project files..."
+for file in debian/patches/*.dpatch; do
+ patch -p1 < "$file"
+done
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+LDFLAGS="-lcurses" \
+make
+
+# Manual installation follows...
+mkdir -p $PKG/usr/games # binaries
+cp -p sl sl-h $PKG/usr/games
+( cd $PKG/usr/games; ln -s sl LS; )
+mkdir -p $PKG/usr/man # man pages
+( cd $PKG/usr/man
+ mkdir -p man6 de/man6 de.UTF-8/man6 ja/man6 ja.UTF-8/man6
+)
+( cd debian/man
+ cp -p man6/* $PKG/usr/man/man6/
+ cp -p de/* $PKG/usr/man/de/man6/
+ cp -p de.UTF-8/* $PKG/usr/man/de.UTF-8/man6/
+ cp -p ja/* $PKG/usr/man/ja/man6/
+ cp -p ja.UTF-8/* $PKG/usr/man/ja.UTF-8/man6/
+)
+# End of manual installation
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-${VERSION}_$PATCHLEVEL
+cp -a debian/README* debian/changelog debian/copyright \
+ $PKG/usr/doc/$PRGNAM-${VERSION}_$PATCHLEVEL
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-${VERSION}_$PATCHLEVEL/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$PATCHLEVEL-$ARCH-$BUILD$TAG.tgz
diff --git a/games/sl/sl.info b/games/sl/sl.info
new file mode 100644
index 0000000000..c0006c7914
--- /dev/null
+++ b/games/sl/sl.info
@@ -0,0 +1,12 @@
+PRGNAM="sl"
+VERSION="3.03_16"
+HOMEPAGE="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html"
+DOWNLOAD="http://ftp.de.debian.org/debian/pool/main/s/sl/sl_3.03.orig.tar.gz \
+ http://ftp.de.debian.org/debian/pool/main/s/sl/sl_3.03-16.diff.gz"
+MD5SUM="d0d997b964bb3478f7f4968eee13c698 \
+ c6c20604f3f07e0149108fa5220de4b3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="V'yacheslav Stetskevych"
+EMAIL="slava18@gmail.com"
+APPROVED="michiel"
diff --git a/games/sl/slack-desc b/games/sl/slack-desc
new file mode 100644
index 0000000000..a167e75f5b
--- /dev/null
+++ b/games/sl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+sl:
+sl: Sl is a program that can display animations aimed to correct you if
+sl: you type sl instead of ls by mistake. Sl stands for Steam Locomotive.
+sl:
+sl: As the original version of this program is no longer maintained,
+sl: this build uses the Debian patchset to bring it up-to-date.
+sl:
+sl: Original homepage:
+sl: http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html
+sl: Patchset:
+sl: http://packages.debian.org/squeeze/sl