summaryrefslogtreecommitdiffstats
path: root/games/yabause
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2016-08-29 20:11:47 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-09-03 07:48:48 +0700
commitb3f8bebe402ba5f6d2ef7ec98eede98529091dfe (patch)
treed09c1fb437acd4b7633b7afe8aa31cce37bf10f7 /games/yabause
parent6072c126b577b309e62fc4d94b1804650f3eb50c (diff)
downloadslackbuilds-b3f8bebe402ba5f6d2ef7ec98eede98529091dfe.tar.gz
slackbuilds-b3f8bebe402ba5f6d2ef7ec98eede98529091dfe.tar.xz
games/yabause: Updated for version 0.9.15
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'games/yabause')
-rw-r--r--games/yabause/README3
-rw-r--r--games/yabause/doinst.sh1
-rw-r--r--games/yabause/yabause.SlackBuild37
-rw-r--r--games/yabause/yabause.info6
4 files changed, 29 insertions, 18 deletions
diff --git a/games/yabause/README b/games/yabause/README
index 9a112ef5c2..b1d19f3369 100644
--- a/games/yabause/README
+++ b/games/yabause/README
@@ -9,7 +9,8 @@ Yabause is a Sega Saturn emulator. It has the following features:
* joystick support
* region select
-gtkglext, mini18n, OpenAL, SDL2 and qt5 are optional dependencies.
+Optional dependencies: gtkglext, ffmpeg, OpenAL, mini18n, SDL2
+and qt5
By default the QT version of yabause is built. To use the GTK
version, first install gtkglext then pass USE_GUI=gtk to the
diff --git a/games/yabause/doinst.sh b/games/yabause/doinst.sh
index 4e8ba7071d..5fb28930db 100644
--- a/games/yabause/doinst.sh
+++ b/games/yabause/doinst.sh
@@ -1,4 +1,3 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
-
diff --git a/games/yabause/yabause.SlackBuild b/games/yabause/yabause.SlackBuild
index 84f136db31..b3706d90fd 100644
--- a/games/yabause/yabause.SlackBuild
+++ b/games/yabause/yabause.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for yabause
-# Copyright 2011-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2011-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=yabause
-VERSION=${VERSION:-0.9.14}
+VERSION=${VERSION:-0.9.15}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,16 +64,23 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Variable to determine gtk/qt interface. Default is qt.
USE_GUI=${USE_GUI:-qt}
# Fix location of man file.
sed -i 's|share/man|man|' src/CMakeLists.txt
+# Fix png files.
+# Eg.: ibpng warning: iCCP: known incorrect sRGB profile
+for pic in $(find . -name "*\.png");do
+ convert $pic ${pic}.new
+ touch -r $pic ${pic}.new
+ mv ${pic}.new $pic
+done
mkdir build
cd build
@@ -81,16 +88,22 @@ cd build
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DYAB_USE_CXX:BOOL=ON \
+ -DYAB_WANT_MPEG:BOOL=ON \
+ -DYAB_USE_SSF:BOOL=ON \
+ -DYAB_USE_SCSP2:BOOL=OFF \
+ -DYAB_USE_SCSPMIDI:BOOL=ON \
+ -DYAB_MAN_DIR:PATH="man" \
-DYAB_PORTS="$USE_GUI" \
- -DYAB_MULTIBUILD=OFF \
- -DYAB_NETWORK=ON \
- -DYAB_OPTIMIZED_DMA=ON \
+ -DYAB_MULTIBUILD:BOOL=OFF \
+ -DYAB_NETWORK:BOOL=ON \
+ -DYAB_OPTIMIZED_DMA:BOOL=ON \
-DGDKGLEXT_CONFIG_INCLUDE_DIR:PATH="/usr/lib${LIBDIRSUFFIX}/gtkglext-1.0/include" \
-DCMAKE_BUILD_TYPE=Release ..
make VERBOSE=1
make install DESTDIR=$PKG
-cd ..
+cd -
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -98,9 +111,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS ChangeLog COPYING GOALS INSTALL README{,.LIN,.QT} TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/games/yabause/yabause.info b/games/yabause/yabause.info
index e7e2676e4f..38869288c5 100644
--- a/games/yabause/yabause.info
+++ b/games/yabause/yabause.info
@@ -1,8 +1,8 @@
PRGNAM="yabause"
-VERSION="0.9.14"
+VERSION="0.9.15"
HOMEPAGE="http://yabause.org/"
-DOWNLOAD="http://downloads.sourceforge.net/yabause/yabause-0.9.14.tar.gz"
-MD5SUM="c9248b31a1484fc72f55958afe742b82"
+DOWNLOAD="https://download.tuxfamily.org/yabause/releases/0.9.15/yabause-0.9.15.tar.gz"
+MD5SUM="efcf00e038ec24c8310285f87e61d579"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""