summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Philip van der Hoeven <philip@vd-hoeven.nl>2018-02-28 08:36:58 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-02-28 08:36:58 +0700
commit25cd11e2f0ea5c3779ca6b3ae35061e1370a31d0 (patch)
tree1f84e84e89014f0c5c415a8fa2d77a08b4fc5203 /games
parent00dd1087fea09063b3738f1d6048d5e5ceca8529 (diff)
downloadslackbuilds-25cd11e2f0ea5c3779ca6b3ae35061e1370a31d0.tar.gz
slackbuilds-25cd11e2f0ea5c3779ca6b3ae35061e1370a31d0.tar.xz
games/openmsx: Added dmk tools from Contrib.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/openmsx/openmsx.SlackBuild14
-rw-r--r--games/openmsx/openmsx.info2
2 files changed, 13 insertions, 3 deletions
diff --git a/games/openmsx/openmsx.SlackBuild b/games/openmsx/openmsx.SlackBuild
index 4c8c6da7e1..fa13ee95e8 100644
--- a/games/openmsx/openmsx.SlackBuild
+++ b/games/openmsx/openmsx.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for OpenMSX
# Copyright 2013-2014 Erwin van Zanten, Dordrecht, The Netherlands
-# Copyright 2016-2017 Philip van der Hoeven, Almere, The Netherlands
+# Copyright 2016-2018 Philip van der Hoeven, Almere, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=openmsx
VERSION=${VERSION:-0.14.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -81,6 +81,16 @@ echo "INSTALL_BINARY_DIR:=/usr/bin" >> build/custom.mk
make
make install DESTDIR=$PKG
+# Build DMK tools
+cd Contrib/dmk
+for DMKTOOL in analyze-dmk combine-dmk der2dmk dsk2dmk empty-dmk svi2dmk; do
+ echo "Building $DMKTOOL"
+ g++ -std=c++11 $SLKCFLAGS -o $DMKTOOL $DMKTOOL.cc
+ cp $DMKTOOL $PKG/usr/bin
+ chmod 755 $PKG/usr/bin/$DMKTOOL
+done
+cd ../..
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/games/openmsx/openmsx.info b/games/openmsx/openmsx.info
index b241608888..d97cc67229 100644
--- a/games/openmsx/openmsx.info
+++ b/games/openmsx/openmsx.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/openMSX/openMSX/releases/download/RELEASE_0_14_0/op
MD5SUM="5407cae76a3e5a4ce808b4ded2255eba"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="libxml++"
+REQUIRES=""
MAINTAINER="Philip van der Hoeven"
EMAIL="philip@vd-hoeven.nl"