summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author M.Dinslage <daedra1{at}charter{dot}net>2010-05-13 00:58:09 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-13 00:58:09 +0200
commitfa3f7f98d2af3e385be632aa3bc9a5a1e0e17dcc (patch)
treebcb0e5397640a11e8ce93d462c6d65a84e7f3ea5 /games
parent86d82bb6852264cf20cc262791caa6110001dd0b (diff)
downloadslackbuilds-fa3f7f98d2af3e385be632aa3bc9a5a1e0e17dcc.tar.gz
slackbuilds-fa3f7f98d2af3e385be632aa3bc9a5a1e0e17dcc.tar.xz
games/fceux: Added to 13.0 repository
Diffstat (limited to 'games')
-rw-r--r--games/fceux/README8
-rw-r--r--games/fceux/doinst.sh4
-rw-r--r--games/fceux/fceux.SlackBuild84
-rw-r--r--games/fceux/fceux.info10
-rw-r--r--games/fceux/slack-desc19
5 files changed, 125 insertions, 0 deletions
diff --git a/games/fceux/README b/games/fceux/README
new file mode 100644
index 0000000000..1b2d1785b3
--- /dev/null
+++ b/games/fceux/README
@@ -0,0 +1,8 @@
+fceux (An 8-bit NES emulator based on FCE Ultra)
+
+fceux is a Nintendo Entertainment System (NES), Famicom, and
+Famicom Disk System (FDS) emulator. It supports both PAL
+(European) and NTSC (USA/JPN) modes. It supports both Windows
+and SDL versions for cross compatibility.
+
+This requires scons and zenity.
diff --git a/games/fceux/doinst.sh b/games/fceux/doinst.sh
new file mode 100644
index 0000000000..a9ca196938
--- /dev/null
+++ b/games/fceux/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications 2>/dev/null
+fi
+
diff --git a/games/fceux/fceux.SlackBuild b/games/fceux/fceux.SlackBuild
new file mode 100644
index 0000000000..d3a87e9134
--- /dev/null
+++ b/games/fceux/fceux.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for fceux
+
+# Written by M.Dinslage (daedra1@charter.net)
+
+PRGNAM=fceux
+VERSION=${VERSION:-2.1.2}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-4}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.src.tar.bz2
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Build fceux
+cd $TMP/fceu
+scons
+mkdir -p $PKG/usr/bin
+install -m 0755 bin/fceux $PKG/usr/bin
+mkdir -p $PKG/usr/man/man6
+install -m 0644 documentation/fceux.6 $PKG/usr/man/man6
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/fceux
+cp -a \
+ bin/fceux.chm COPYING INSTALL NEWS README TODO-PROJECT \
+ $PKG/usr/doc/$PRGNAM-$VERSION/fceux
+
+# Buidl gfceux
+cd $TMP/gfceux
+python setup.py install --prefix=$PKG/usr
+mkdir -p $PKG/usr/man/man1
+mv $PKG/usr/share/man/man1/gfceux.1 $PKG/usr/man/man1
+gzip -9 $PKG/usr/man/man?/*
+rm -rf $PKG/usr/share/man
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/gfceux
+cp -a \
+ ChangeLog COPYING INSTALL TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION/gfceux
+
+# This is supposed to work with gtk+2-2.14.x as well...
+sed -i "s%2.16%2.14%" $PKG/usr/share/gfceux/gfceux.glade
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/fceux/fceux.info b/games/fceux/fceux.info
new file mode 100644
index 0000000000..ae408d1113
--- /dev/null
+++ b/games/fceux/fceux.info
@@ -0,0 +1,10 @@
+PRGNAM="fceux"
+VERSION="2.1.2"
+HOMEPAGE="http://fceux.com/web/home.html"
+DOWNLOAD="http://sourceforge.net/projects/fceultra/files/Source%20Code/2.1.2%20src/fceux-2.1.2.src.tar.bz2/download"
+MD5SUM="dbb9332e03c380de181e18ef3a75b6d1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="M.Dinslage"
+EMAIL="daedra1{at}charter{dot}net"
+APPROVED="rworkman"
diff --git a/games/fceux/slack-desc b/games/fceux/slack-desc
new file mode 100644
index 0000000000..b1daf67eb5
--- /dev/null
+++ b/games/fceux/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+fceux: fceux (An 8-bit NES emulator based on FCE Ultra)
+fceux:
+fceux: fceux is a Nintendo Entertainment System (NES), Famicom, and
+fceux: Famicom Disk System (FDS) emulator. It supports both PAL
+fceux: (European) and NTSC (USA/JPN) modes. It supports both Windows
+fceux: and SDL versions for cross compatibility.
+fceux:
+fceux:
+fceux:
+fceux:
+fceux: