summaryrefslogtreecommitdiffstats
path: root/gis/OWSLib
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-03-07 08:39:33 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-10 07:11:07 +0700
commitb389c76742aed569691886d523f1b8e840f8dc87 (patch)
tree348c757611d491e5a3fb85d99415982a3abbb647 /gis/OWSLib
parentfbc64cf9f84481cee4f844f259ac9e6b75aa3046 (diff)
downloadslackbuilds-b389c76742aed569691886d523f1b8e840f8dc87.tar.gz
slackbuilds-b389c76742aed569691886d523f1b8e840f8dc87.tar.xz
gis/OWSLib: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'gis/OWSLib')
-rw-r--r--gis/OWSLib/OWSLib.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/gis/OWSLib/OWSLib.SlackBuild b/gis/OWSLib/OWSLib.SlackBuild
index 34f8795292..948c6e9d11 100644
--- a/gis/OWSLib/OWSLib.SlackBuild
+++ b/gis/OWSLib/OWSLib.SlackBuild
@@ -70,6 +70,9 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true