summaryrefslogtreecommitdiffstats
path: root/gis/gdal
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2018-02-24 15:01:55 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-03 08:42:06 +0700
commit188a6db96c886b37a36cd5d7951356a090fe36a8 (patch)
tree4f0b82cd0d2ae8b611be3fa5a93edbbd7946c758 /gis/gdal
parentac29f11f3121063912f4d3b4f16a087d700bb195 (diff)
downloadslackbuilds-188a6db96c886b37a36cd5d7951356a090fe36a8.tar.gz
slackbuilds-188a6db96c886b37a36cd5d7951356a090fe36a8.tar.xz
gis/gdal: Add python3 support.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'gis/gdal')
-rw-r--r--gis/gdal/README2
-rw-r--r--gis/gdal/gdal.SlackBuild8
2 files changed, 9 insertions, 1 deletions
diff --git a/gis/gdal/README b/gis/gdal/README
index 064469fb17..c959862f44 100644
--- a/gis/gdal/README
+++ b/gis/gdal/README
@@ -11,7 +11,7 @@ provides a similar capability for simple features vector data.
The following optional requirements are detected automatically:
cfitsio, freexl, hdf, hdf5, libkml, libwebp, netcdf,
- postgresql, xerces-c
+ postgresql, python3, xerces-c
To enable OpenCL GPU-accelerated performance, specify the option
OPENCL=yes (requires opencl-headers to build, and either nvidia-driver
diff --git a/gis/gdal/gdal.SlackBuild b/gis/gdal/gdal.SlackBuild
index 3e16baad69..be5ff762f8 100644
--- a/gis/gdal/gdal.SlackBuild
+++ b/gis/gdal/gdal.SlackBuild
@@ -143,6 +143,14 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ cd swig/python
+ rm -rf build
+ python3 setup.py build
+ python3 setup.py install --root=$PKG --prefix=/usr
+ cd - >/dev/null
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true