summaryrefslogtreecommitdiffstats
path: root/gis/saga-gis
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2014-08-03 16:27:08 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-08-03 16:27:08 +0700
commitc55d1f99e7d157cb5fd708dbb7be746ed5747e87 (patch)
treee7f7a9d9dd7dd1d9808b5fcf62f819b6d770bca7 /gis/saga-gis
parent34c4c0d19891e8b8842d8d8db9438c36fbfa7a1e (diff)
downloadslackbuilds-c55d1f99e7d157cb5fd708dbb7be746ed5747e87.tar.gz
slackbuilds-c55d1f99e7d157cb5fd708dbb7be746ed5747e87.tar.xz
gis/saga-gis: Added (Geographic Information System).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis/saga-gis')
-rw-r--r--gis/saga-gis/README9
-rw-r--r--gis/saga-gis/saga-gis.SlackBuild108
-rw-r--r--gis/saga-gis/saga-gis.info10
-rw-r--r--gis/saga-gis/slack-desc19
4 files changed, 146 insertions, 0 deletions
diff --git a/gis/saga-gis/README b/gis/saga-gis/README
new file mode 100644
index 0000000000..08216175ec
--- /dev/null
+++ b/gis/saga-gis/README
@@ -0,0 +1,9 @@
+System for Automated Geoscientific Analyses (SAGA) is a Geographic Information
+System software with immense capabilities for geodata processing and analysis.
+
+SAGA supports the implementation of new functions with an effective API.
+Functions are organised as modules in framework independent Module Libraries
+and can be accessed via SAGA’s Graphical User Interface or various scripting
+environments (shell scripts, Python, R and so on).
+
+SAGA can use these optional dependencies: postgresql, opencv and vigra.
diff --git a/gis/saga-gis/saga-gis.SlackBuild b/gis/saga-gis/saga-gis.SlackBuild
new file mode 100644
index 0000000000..c86622b071
--- /dev/null
+++ b/gis/saga-gis/saga-gis.SlackBuild
@@ -0,0 +1,108 @@
+#!/bin/sh
+
+# Slackware build script for saga-gis
+
+# Copyright 2014 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=saga
+PKGNAM=${PRGNAM}-gis
+VERSION=${VERSION:-2.1.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+SRCNAM=${PRGNAM}_${VERSION}_src
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM
+unzip $CWD/$SRCNAM.zip
+cd $SRCNAM/$PKGNAM
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -e '\#src/modules/imagery/imagery_photogrammetry/Makefile#d' -i configure.ac
+aclocal
+autoheader
+libtoolize
+automake --add-missing
+autoreconf -i
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --build=$ARCH \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --enable-python \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog NEWS README $PKG/usr/doc/$PKGNAM-$VERSION
+cat $CWD/$PKGNAM.SlackBuild > $PKG/usr/doc/$PKGNAM-$VERSION/$PKGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/saga-gis/saga-gis.info b/gis/saga-gis/saga-gis.info
new file mode 100644
index 0000000000..398fe1d252
--- /dev/null
+++ b/gis/saga-gis/saga-gis.info
@@ -0,0 +1,10 @@
+PRGNAM="saga-gis"
+VERSION="2.1.2"
+HOMEPAGE="http://www.saga-gis.org"
+DOWNLOAD="http://sourceforge.net/projects/saga-gis/files/SAGA%20-%202.1/SAGA%202.1.2/saga_2.1.2_src.zip"
+MD5SUM="527f4c703cfd4c28296728b00131dd9c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="gdal unixODBC wxGTK3"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/saga-gis/slack-desc b/gis/saga-gis/slack-desc
new file mode 100644
index 0000000000..a11f962234
--- /dev/null
+++ b/gis/saga-gis/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+saga-gis: saga-gis (Geographic Information System)
+saga-gis:
+saga-gis: System for Automated Geoscientific Analyses (SAGA) is a Geographic
+saga-gis: Information System (GIS) software with immense capabilities for
+saga-gis: geodata processing and analysis.
+saga-gis:
+saga-gis:
+saga-gis:
+saga-gis:
+saga-gis:
+saga-gis: