summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Vincent Batts <vbatts@hashbangbash.com>2011-06-05 12:16:48 +0200
committer Robby Workman <rworkman@slackbuilds.org>2011-06-13 01:34:12 -0400
commit07be6f24086d317225ba7c8954c2a61f8d28929b (patch)
treee4f4aca03f46fee18624a3c7fc7cdc13efd1f7a5 /graphics
parent6c7dd0cc6b1976cd55505b90f5953d578116f2f6 (diff)
downloadslackbuilds-07be6f24086d317225ba7c8954c2a61f8d28929b.tar.gz
slackbuilds-07be6f24086d317225ba7c8954c2a61f8d28929b.tar.xz
graphics/dblatex: Added (A DocBook to LaTeX Publisher)
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dblatex/README15
-rw-r--r--graphics/dblatex/dblatex.SlackBuild74
-rw-r--r--graphics/dblatex/dblatex.info10
-rw-r--r--graphics/dblatex/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/graphics/dblatex/README b/graphics/dblatex/README
new file mode 100644
index 0000000000..ca9dc8f0a9
--- /dev/null
+++ b/graphics/dblatex/README
@@ -0,0 +1,15 @@
+dblatex (DocBook to LaTeX Publishing)
+
+Dblatex started as a DB2LaTeX clone, but since then many things have
+changed and new features have been added or (hopefully) improved. Now,
+the portion of shared code is small if any, and the dblatex purpose is
+different from DB2LaTeX on these points:
+* The project is end-user oriented, that is, it tries to hide as much
+ as possible the latex compiling stuff by providing a single clean
+ script to produce directly DVI, PostScript and PDF output.
+* The actual output rendering is done not only by the XSL stylesheets
+ transformation, but also by a dedicated LaTeX package. The goal is to
+ allow a deep LaTeX customisation without changing the XSL stylesheets.
+* Post-processing is done by Python, to make publication faster,
+ convert the images if needed, and do the whole compilation.
+
diff --git a/graphics/dblatex/dblatex.SlackBuild b/graphics/dblatex/dblatex.SlackBuild
new file mode 100644
index 0000000000..c91366699c
--- /dev/null
+++ b/graphics/dblatex/dblatex.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackware build script for dblatex
+
+# Written by Vincent Batts, vbatts@hashbangbash.com
+
+PRGNAM=dblatex
+VERSION=${VERSION:-0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.*z?
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr/
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYRIGHT \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mv $PKG/usr/share/doc/* $PKG/usr/doc/$PRGNAM-$VERSION/
+rm -r $PKG/usr/share/doc/
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/dblatex/dblatex.info b/graphics/dblatex/dblatex.info
new file mode 100644
index 0000000000..4e87b5f38c
--- /dev/null
+++ b/graphics/dblatex/dblatex.info
@@ -0,0 +1,10 @@
+PRGNAM="dblatex"
+VERSION="0.3"
+HOMEPAGE="http://dblatex.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/dblatex/dblatex-0.3.tar.bz2"
+MD5SUM="7de6bf72b8b2934169ce0ec911e966ed"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Vincent Batts"
+EMAIL="vbatts@hashbangbash.com"
+APPROVED="pprkut"
diff --git a/graphics/dblatex/slack-desc b/graphics/dblatex/slack-desc
new file mode 100644
index 0000000000..4490e2b31b
--- /dev/null
+++ b/graphics/dblatex/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+dblatex: dblatex (DocBook to LaTeX Publishing)
+dblatex:
+dblatex: Dblatex transforms a DocBook XML/SGML document to LaTeX. Once
+dblatex: transformed into LaTeX, standard LaTeX tools are used to produce
+dblatex: DVI, Postcript or PDF files.
+dblatex:
+dblatex:
+dblatex:
+dblatex:
+dblatex:
+dblatex: