summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Michael Wagner <lapinours@web.de>2010-05-11 20:00:35 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:00:35 +0200
commit9cb923ae531765033ab9aad9d45b8d7119900caf (patch)
tree32d50da10c98ca07b6b4d1edb8e90d69d99ad7dc /graphics
parent93e5d5329cd01cbfa24a3c10f821ab3ea32f03e4 (diff)
downloadslackbuilds-9cb923ae531765033ab9aad9d45b8d7119900caf.tar.gz
slackbuilds-9cb923ae531765033ab9aad9d45b8d7119900caf.tar.xz
graphics/fbida: Added to 12.0 repository
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fbida/README7
-rw-r--r--graphics/fbida/fbida.SlackBuild72
-rw-r--r--graphics/fbida/fbida.info8
-rw-r--r--graphics/fbida/slack-desc19
4 files changed, 106 insertions, 0 deletions
diff --git a/graphics/fbida/README b/graphics/fbida/README
new file mode 100644
index 0000000000..0d4be6d168
--- /dev/null
+++ b/graphics/fbida/README
@@ -0,0 +1,7 @@
+fbida (image viewer)
+
+The fbida project contains a few applications for viewing and
+editing images, with the main focus being photos.
+
+ida (a Motif based image viewer for X11) is not included on purpose,
+as it needs Open Motif.
diff --git a/graphics/fbida/fbida.SlackBuild b/graphics/fbida/fbida.SlackBuild
new file mode 100644
index 0000000000..e02f376067
--- /dev/null
+++ b/graphics/fbida/fbida.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for fbida
+
+# (C) 2007 Michael Wagner <lapinours@web.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=fbida
+VERSION=2.06
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="COPYING Changes INSTALL README TODO"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# "Patch" GNUmakefile and mk/Autoconf.mk
+for i in GNUmakefile mk/Autoconf.mk; do
+ sed -i s,/X11R6,, $i || exit 1
+done
+
+CFLAGS="$SLKCFLAGS" make HAVE_MOTIF=no || exit 1
+prefix=/usr make install DESTDIR=$PKG HAVE_MOTIF=no || exit 1
+
+mv $PKG/usr/share/man $PKG/usr && rm -rf $PKG/usr/share
+gzip -9 $PKG/usr/man/man1/* 2> /dev/null
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/graphics/fbida/fbida.info b/graphics/fbida/fbida.info
new file mode 100644
index 0000000000..7438b7bb55
--- /dev/null
+++ b/graphics/fbida/fbida.info
@@ -0,0 +1,8 @@
+PRGNAM="fbida"
+VERSION="2.06"
+HOMEPAGE="http://linux.bytesex.org/fbida/"
+DOWNLOAD="http://dl.bytesex.org/releases/fbida/fbida-2.06.tar.gz"
+MD5SUM="1f78e9a83fb546660a024a4bc0580ace"
+MAINTAINER="Michael Wagner"
+EMAIL="lapinours@web.de"
+APPROVED="rworkman"
diff --git a/graphics/fbida/slack-desc b/graphics/fbida/slack-desc
new file mode 100644
index 0000000000..d2dcf59842
--- /dev/null
+++ b/graphics/fbida/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+fbida: fbida (image viewer)
+fbida:
+fbida: The fbida project contains a few applications for viewing and
+fbida: editing images, with the main focus being photos.
+fbida:
+fbida: Homepage: http://linux.bytesex.org/fbida/
+fbida:
+fbida:
+fbida:
+fbida:
+fbida: